Support » Plugin: WooCommerce » Reviews / Rating Tab Not Being Displayed

  • Resolved benstewart906

    (@benstewart906)


    Hello world, I’m trying to add the “Reviews” and “Rating” tabs to my WooCommerce product and for the life of me can’t figure out what I’m doing wrong. Within the product dashboard advanced options I’ve checked “Enable Reviews”. Within the WooCommerce setting I’ve checked “Enable Product Reviews”. I’ve tried adding products after I’ve checked these settings, cleared my cache, etc. but to no avail. Does anyone have any insight here? Thanks!

    Password for development URL is “dev”.

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Bump. Any thoughts? Thanks!

    Making progress here: when I activated the “2017” theme, the Reviews tab displayed, so it is a theme issue.

    Here is a list of everything I’ve done so far that has not worked with my custom theme:

    – Within the Product Quick Edit, I’ve checked “Enable Reviews”
    – Within WooCommerce » Settings » Products, I’ve checked “Enable product reviews”
    – Within this same dashboard, I’ve also un-checked “Reviews can only be left by verified owners”
    – I’ve left a single placeholder review on the single product, which is “Approved” within the “Comments” section of the dashboard
    – I’ve deactivated all plugins to no avail.
    – I’ve inspected the code within the tabs and there is no CSS that is hiding the Reviews tab; it simply is not loading.

    Is there somewhere in my function I need to declare usage of the Reviews feature?

    Solved! I simply needed to declare WooCommerce support in functions.php and the tab was added:

    function mytheme_add_woocommerce_support() {
    add_theme_support( ‘woocommerce’ );
    }
    add_action( ‘after_setup_theme’, ‘mytheme_add_woocommerce_support’ );

    Hope this helps someone in the future!

    tobydi

    (@tobydi)

    @benstewart906

    Thanks so much for posting your progress here and for also leaving a solution.

    This fixed my problem as well!!

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Reviews / Rating Tab Not Being Displayed’ is closed to new replies.