Support » Plugin: Reviews and Rating – Google My Business » Review not showing

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Design Extreme

    (@designextreme)

    @eddierosenthal I can see the plugin is installed and active.

    I cannot see any trace of the Shortcode in the page.

    [reviews_rating_link maps_link]View Location on Google Maps[/reviews_rating_link]

    If you’re using a visual editor, please check for a Shortcode, HTML or Code block (or similar) that will run the Shortcode. If you’re using Gutenburg, you can select the Shortcode block to insert this.

    • This reply was modified 1 year, 6 months ago by Design Extreme.
    • This reply was modified 1 year, 6 months ago by Design Extreme. Reason: Added Shortcode example
    Thread Starter eddierosenthal

    (@eddierosenthal)

    i added a shortcode to show a gravity form right below , to prove to myself that the page shows shortcodes, and to rule out some strangeness from oxygen page builder.
    the whole code from the page is

    [reviews_rating_link maps_link]View Location on Google Maps[/reviews_rating_link]
    
    [gravityform id="1" title="true" description="true"]

    if i do not have any reviews what would show up? perhaps it is not the right api being setup??

    Plugin Author Design Extreme

    (@designextreme)

    @eddierosenthal Have you tried the basic Shortcode:

    [reviews_rating]

    I still cannot see any reference to this plugin’s Shortcode on this page. You will need the correct Place ID and all the steps followed in the guide to load data from the Places API.

    Perhaps try Demo mode briefly if you’re unsure? This way you can see the link appear and you’ll know it’s the plugin rather than how the Shortcode is placed on the page (or its editor).

    Thread Starter eddierosenthal

    (@eddierosenthal)

    i can see the demo ok.
    i am reworking the api stuff.
    in the OA credentials, do i need to fill that out?

    Plugin Author Design Extreme

    (@designextreme)

    @eddierosenthal I think you may be in the wrong place within the API Key setup… You don’t need to add OA Credentials.

    Please recheck the guide or view the visual setup guide. You want to Enable Places API and create an API Key with a couple of restrictions, including just Places API.

    Also, if you can see the “Retrieved Data” in the plugin’s settings – this will offer errors if it has tried and failed to get the data for your place.

    • This reply was modified 1 year, 6 months ago by Design Extreme. Reason: Clarity
    Thread Starter eddierosenthal

    (@eddierosenthal)

    status from the retrieval was

    {
        "html_attributions": [],
        "result": {
            "formatted_address": "681 Aztec Ave, Corvallis, OR 97330, USA",
            "icon": "https://maps.gstatic.com/mapfiles/place_api/icons/v1/png_71/geocode-71.png",
            "name": "681 Aztec Ave",
            "url": "https://maps.google.com/?q=681+Aztec+Ave,+Corvallis,+OR+97330,+USA&ftid=0x54c03f9049475f03:0x67a7a03988968c29",
            "vicinity": "Corvallis"
        },
        "status": "OK"
    }

    with dummy on i can see the dummy data.
    if i look up on google i can see i have two reviews

    Merchant Logo
    Higher Source Sites
    5.0
    2 Google reviews
    Website designer in Corvallis, Oregon
    
    i did go thru point by point. 
    on the page in normal WP i see 
    

    [reviews_rating]

    [reviews_rating_link maps_link]View Location on Google Maps[/reviews_rating_link]

     

    [gravityform id=”1″ title=”true” description=”true”]`

    so sorry this is such a bother.

    Plugin Author Design Extreme

    (@designextreme)

    @eddierosenthal You’re using the wrong Place ID. Please search for your business’s name, not the address.

    Your Place ID is: ChIJzSWOr2FIhIARxK0HD5zg0zs

    Thread Starter eddierosenthal

    (@eddierosenthal)

    wow! thanks so much for all your help!

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Review not showing’ is closed to new replies.