Support » Plugin: IP Based Login » Reverse proxy

  • Resolved matousgahut

    (@matousgahut)


    Unable to login using this plugin.

    Problem when running behind a reverse proxy, REMOTE_ADDR header is checked before HTTP_X_FORWARDED_FOR.

    We had to edit getip function so HTTP_X_FORWARDED_FOR is checked first to fix this.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author brijeshk89

    (@brijeshk89)

    Hi,

    Thank you for reporting the issue.

    I have fixed it and released a new version of the plugin 1.4.5

    Please update and let us know if it worked.

    We authenticate users to WordPress who arrive by way of a specific proxy. With this issue resolved, this plugin now sees our user’s HTTP_X_FORWARDED_FOR address rather than the REMOTE_ADDR which is what we want.

    Would it be possible to add an option in this plugin’s settings to “ignore proxies?” This way proxies won’t break what matousgahut requires above but will also allow others (like us) to continue authenticating proxy users.

    Thanks!

    Plugin Author brijeshk89

    (@brijeshk89)

    Hi,

    @neilgrabowsky Understood. I have released 1.4.6 today in which the default IP detection will be done as it used to work in IP Based Login v1.4.4 and previous versions.

    For users who want to use other method for IP detection like HTTP_X_FORWARDED_FOR can go to IP Based login Settings page and select the IP Detection Preference as per the preference.

    @matousgahut You can upgrade to 1.4.6 and select the IP detection preference.

    Hope this resolves the issue for both of you 🙂

    Tested and confirmed working. Thank you very much.

    Plugin Author brijeshk89

    (@brijeshk89)

    Glad to know it works !

    It would be great if you could leave a review for the plugin 🙂

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.