Reverse order (4 posts)

  1. howiebar
    Posted 8 years ago #

    Otto42 shutting down the topic is not helping the user. Stating that IPOWER is not using the version of MySQL that they advertise without telling us which version they ARE using stretches credibility. Isn't this support forum supposed to help your USER?? Shutting down the topic doesn't do that.

    I am in need of good tech support. This ain't it.

    Howie Barte

  2. mpelzsherman
    Posted 8 years ago #

    I have to agree with Howie. MySQL is clearly to blame for this, but they have not yet released a GA version that fixes the problem, so you can't really blame our hosting providers for not wanting to upgrade.

    In my case, upgrading WordPress is very painful since I'm on 2.0.2 and there is no easy upgrade script to get me to 2.5. And even so, apparently 2.5 still runs into the MySQL problem.

    It seems to me that the MySQL bug only occurs when doing a GROUP BY on just the primary key. As pointed out here:

    "This can be worked around by simply removing the GROUP BY clause. Using GROUP BY on a unique index (a Primary Key, of course, is a unique index) is pointless as each row will by definition be its own group."

    I am working on a patch for this issue but I could use some help.
    If anyone is interested please shoot me an email (mpelzsherman at yahoo.com).

  3. Ivovic
    Posted 8 years ago #

    I think the point is that jumping up and down about it here, isn't going to fix MySQL. Ideally, you should be posting about this on the MySQL site since the problem is actually with them.

  4. mpelzsherman
    Posted 8 years ago #

    Fair enough, although the bug is being tracked by MySQL and they have already fixed it, but they haven't seen fit to issue an update to their GA release.

    BTW, I did find a workaround for WP 2.0.2, posted here.

Topic Closed

This topic has been closed to new replies.

About this Topic