Support » Plugin: Google CSE » Returns results, but the links are broken

Viewing 12 replies - 1 through 12 (of 12 total)
  • I have the same problem…

    V

    (@vitaliss)

    Hi jmbis, what wp theme do you use? Cheers, V

    Hi vitaliss, I use Mystique 3.3.2 theme with wp 3.6.1

    Plugin Author ptz0n

    (@ptz0n)

    Hi there & thanks for the issue report.

    I will do some tests with the Mystique theme and get back to you.

    V

    (@vitaliss)

    I use Enfold. Both Mystyque and Enfold support bbpress, could it have something to do with this?

    V

    (@vitaliss)

    Hi ptz0n,
    have you tested it?
    Thanks 🙂

    I have the same issue. Using PageLines.

    A little trick that makes the plugin work with twentyfourteen/WP3.8. See a live example here: http://www.fclose.com/?s=wordpress

    diff --git a/wp-content/themes/twentyfourteen/content.php b/wp-content/themes/twentyfourteen/content.php
    index a793fed..28931ef 100644
    --- a/wp-content/themes/twentyfourteen/content.php
    +++ b/wp-content/themes/twentyfourteen/content.php
    @@ -24,7 +24,11 @@
                            if ( is_single() ) :
                                    the_title( '<h1 class="entry-title">', '</h1>' );
                            else :
    -                               the_title( '<h1 class="entry-title"><a href="' . esc_url( get_permalink() ) . '" rel="bookmark">', '</a></h1>' );
    +                // zma hacking: make it work with the google-cse plugin
    +                               // the_title( '<h1 class="entry-title"><a href="' . esc_url( get_permalink() ) . '" rel="bookmark">', '</a></h1>' );
    +        ?>
    +                <h1 class="entry-title"><a href="<?php the_permalink(); ?>" rel="bookmark"><?php the_title(); ?></a></h1>
    +               <?php
                            endif;
                    ?>

    But it will be great if this is fixed in Google-CSE.

    V

    (@vitaliss)

    There is a new version of the plugin. I tested my setup with it, but it still doesn’t work. What do you need to solve this?

    I have the same issue as vitaliss with the same theme.

    digbymaass

    (@digbymaass)

    Searches returning non wordpress results (which you would want if you had legacy html pages in your site) behave like this. They don’t work.

    protsol

    (@protsol)

    I have the same problem, using Bangkok Press. I can’t provide the website but all the results returned end with the search term:

    When I search for “Jane”
    http://dev.yourteenmag.com/?s=Jane

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Returns results, but the links are broken’ is closed to new replies.