Support » Plugin: Email Subscribers & Newsletters » returns “Invalid email address” error

  • Resolved cscc2017

    (@cscc2017)


    I have just installed this plugin as a way for our users to subscribe to new post notifications. When I tested it with an address of my own (from a different browser and not signed-in) I get the error “invalid email address”. I tried it with a couple of different addresses that are known to work otherwise. Have I missed a set up step somewhere?

    The page I need help with: [log in to see the link]

Viewing 15 replies - 16 through 30 (of 46 total)
  • @vmercader @macsip

    We are looking into this on priority. Kindly allow us some time to investigate it in more detail. I would get back to you once this has been thoroughly investigated.

    Same issue – it’s costing me subscribers so please advise asap.
    Was working perfectly until maybe a week ago.

    Same issue – Please help!

    I’m having the same issue on this site: https://www.ellenrobinson.com/

    While you resolve this, where can we download earlier versions of the plugin?

    thanks,
    Lisa

    Does anybody on this forum have older versions of the plugin, or know where to get them? I hate to switch plugins midstream, but need to have something working while this is being investigated. Thanks!

    Problem seems to be solved?! The plugin works again, at least on my website!

    @lisath

    All, the previous versions are always bottom most of the advanced page as link below..

    every version is there..

    https://wordpress.org/plugins/email-subscribers/advanced/

    hope this helps. 🙂

    Andrew

    @andrewmperryman
    Thanks, Andrew.

    @ricysreadingcorner
    That’s great. But it’s still not working on mine! At least not yet.

    The truth is, I’ve never had to revert a plugin to a previous version! What’s the best practice for this, while retaining all settings, etc.? I tried simply de-activating the current version and then installing the older, but that isn’t allowed because the directory already exists.

    • This reply was modified 1 year, 3 months ago by  .

    I have never had any success trying to “back-date” a plugin or any software for that matter. I’m sure someone that reads and writes code can do it, but that’s way over my head. For now I’ve de-activated this plugin until the author comes up with a patch or update. I’ll ride that horse until either the update is available or our members / users complain that it’s too tedious to sign up for our mailing list. On another site I manage I use contact form 7 and the mail chimp plugin, which works fine, but lacks (as near as I can tell) the ability to send email notifications of blog posts (which this site needs)…

    I have the same issue. please resolve it quick so we can continue use your plugin.

    Thanks

    Lovely site for Ellen Robinson @lisath. Small world – I lived in Oakland for 25 years before moving to Portland. I remember hearing her name in music circles.

    same problem…

    “unexpected-error”

    I deleted 3.4.11 and than installed the 3.4.9 and now works again.

    I’m still waiting for a solution with 3.4.11…

    @benlucchesi @macsip @engrdanyalahmed @cscc2017

    I will update you once a new version has been released.

    Do let me know if you need any help further.

Viewing 15 replies - 16 through 30 (of 46 total)
  • The topic ‘returns “Invalid email address” error’ is closed to new replies.