WordPress.org

Forums

Nextend Facebook Connect
Returning blank "Login error!" (8 posts)

  1. ethernick
    Member
    Posted 2 years ago #

    Since upgrading - when users try to sign in they get "Login error!" message

    I've tried rolling to a previous version, and even tried the developer version, same message.

    Any help hunting down the problem would be great.
    Thanks
    Nick

    http://wordpress.org/extend/plugins/nextend-facebook-connect/

  2. zenrhe
    Member
    Posted 2 years ago #

    I just installed this today (on a fresh wp isntall), and get this error too : (

  3. philosaphylas
    Member
    Posted 2 years ago #

    I think I just figured out the issue, at least for me anyways. You need to go in to your WordPress Dashboard, then Settings/Nextend FB Connect, then under Settings you'll see "Fixed redirect url for login:" type in your domain here and then make sure it matches the Site URL in your Facebook App under the "Website with Facebook Login" tab. Then click the 'Save Changes' button in your WP dashboard. Hopefully that helps!

  4. Jorge A. Gonzalez
    Member
    Posted 1 year ago #

    Still getting error after following philosaphylas advice.

  5. Jorge A. Gonzalez
    Member
    Posted 1 year ago #

    HOW TO FIX

    Repair the options table then run DELETE FROM wp_options WHERE option_name like '_site_transient_%'

  6. nickzee
    Member
    Posted 1 year ago #

    I tried both suggestions above.

    And this....
    Better WP Security plugin limitations
    Disable “Filter Suspicious Query Strings” option
    Disable “Reduce comment spam” option
    Disable “Prevent long URL strings” option

    I even disabled Better WP Security completely.

    Any other ideas @nextendweb ?

  7. nickzee
    Member
    Posted 1 year ago #

    Like usual, after hours of tinkering AND posting in a forum, I figure it out!! Minutes later too. haha

    In your FB Developers App
    Settings >> Security -

    YES - Client OAuth Login
    NO - App Secret Proof for Server API calls
    NO - Embedded browser OAuth Login
    NO - Require 2-factor reauthorization

    I had "App Secret Proof for Server API calls" and "Embedded browser OAuth Login" set to yes. Setting them to no fixed it....for me.

    Don't for get to set Better WP to:
    Disable “Filter Suspicious Query Strings” option
    Disable “Reduce comment spam” option
    Disable “Prevent long URL strings” option
    http://www.nextendweb.com/social-connect-plugins-for-wordpress/

  8. mskokure
    Member
    Posted 1 year ago #

    Hi,

    I'm also facing the same problem. I've checked: FB Developers App
    Settings >> Security -

    YES - Client OAuth Login
    NO - App Secret Proof for Server API calls
    NO - Embedded browser OAuth Login
    NO - Require 2-factor reauthorization

    but I'm not install Better WP plugin.. but still facing error login. My page-http://niexter.nst.com.my/wp-login.php Anyone pls help me..

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Nextend Facebook Connect
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.