WordPress.org

Support

Support » Themes and Templates » Retina problems

Retina problems

  • Hello everybody
    Users accessing my blog are generating page not found errors. This causes Wordfence to block these users after a while. The problem seems to be the sites Logo. Swithing off retiana support in the customizr options solves this problem, but…
    From Wordfence I´m getting:
    Enno in Norway left http://sv-inua.net/ and tried to access non-existent page http://sv-inua.net/wp-content/uploads/bloglogo@2x.png
    The name of my logo is “bloglogo.png”.
    The same problem exists with some other images but not all. I do not understand how and when these imagefiles with an @2x extension are created.
    Anyone knows how this can be fixed?
    Thanks
    Enno

Viewing 8 replies - 1 through 8 (of 8 total)
  • ElectricFeet
    Participant

    @electricfeet

    Could you try re-uploading your logo with retina support switched on and see if that fixes it?

    If not, what happens if you change the setting of: “Force logo dimensions to max-width:250px and max-height:100px”

    No, none of this did solve the problem. after uploading the logo I get the following new files in the uploads directory:
    bloglogo-270×67.png
    bloglogo-270×67@2x.png
    bloglogo-500×125.png
    bloglogo-500×125@2x.png
    bloglogo.png
    unfortunately the file bloglogo@2x.png is still missing.
    With usual images inside a post a “regenerate thumbnails” does the job.

    ElectricFeet
    Participant

    @electricfeet

    Just checking: none of my images have an imagename@2x.jpg.

    What makes you think that there should be one?

    Maybe this is just some person typing in that address in the hope of getting a better quality version of your logo? Though I admit, that sounds a bit far-fetched!

    As I understand it those imagname@2x.jpg files are served to clients with a retina display. If I look at the files the images have exactly twice the resolution of the origianl image. Since bloglogo.png is the original image that I uploaded there is no way wordpress could create an image with double resolution without interpolation.
    I tried it with my iPhone and the logo looks quiet fine with high resolution. So I do not know why wordpress is trying to access the @2x file at all.

    Looks like a bug to me.
    Do you know it this code is a part of Customizir or WordPress?

    If you do not have andy @2x file I guess that you did not have retina support on when uploading.

    ElectricFeet
    Participant

    @electricfeet

    Yes, you’re right, d4z_c0nf did some more checking and it looks like it might be a bug. It (what?) shouldn’t be trying to get a bigger version than the original. I don’t think it’s WordPress, because WP doesn’t offer retina support, to my knowledge. Possibilities: the bug might be in:

    • the way that Customizr interfaces with retina.js;
    • the upload functionality;
    • the retina.js display functionality—which may of course have been fixed in a newer version (The Customizr version is an older one, I think.)
    d4z_c0nf
    Participant

    @d4z_c0nf

    Not really convinced about the buggy upload functionality. I think it makes sense not producing a retina version for the original uploaded picture for the reason enro2002 has highlighted:

    Since bloglogo.png is the original image that I uploaded there is no way wordpress could create an image with double resolution without interpolation

    That’s why customizr processes just the already “resized” versions.

    ElectricFeet
    Participant

    @electricfeet

    This thread is interesting: http://stackoverflow.com/questions/13704317/supressing-404s-in-retina-js-library

    One post seems to pretty much say that the 404s are retina.js informing itself which images area available. Can this be right?

    I am seeing these errors in my logs as well:

    213.127.158.226 - - [27/May/2014:14:00:07 +0200] "HEAD /wp-content/gallery/House/Sneeuwklokjestraat/SN_W3_Reb/thumbs/thumbs_Toilet_-_6@2x.JPG HTTP/1.1" 404 379
    213.127.158.226 - - [27/May/2014:14:02:25 +0200] "HEAD /wp-content/uploads/2014/05/2014-05-09-11.53.50@2x.jpg HTTP/1.1" 404 379
    213.127.158.226 - - [27/May/2014:14:02:25 +0200] "HEAD /wp-includes/images/smilies/icon_smile@2x.gif HTTP/1.1" 404 380

    It is a bit annoying, as it clogs up my logs. Switching retina support off in Customizr options gets rid of these errors.
    Please be advised that I am running NextGen Gallery as well, and my images have been imported from my other site.

    Recreating thumbnails, through the Regenerate Thumbnails plugin, did not solve the issue.
    Any ideas?

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Retina problems’ is closed to new replies.