Support » Fixing WordPress » Retarded richtext editor

  • Im using WP2.0 for a week now and i love the options offered in the richtext editor. Tho i run into problems as i use it.

    I’ve been struggling with a page for over an hour now to update 15lines of text and yet its not the way i want. Mostly because of the richtexts annoying behavior. When it looks ok and i save the post/page. I check the page and it turns out to be all wrong. All text is bold which i dont want. I looked at the page source and its totally f*cked up. Useless tags everywhere. Unclosed ones aswell. It makes me cry.

    Is this a browser issue? I use FF 1.5 on all my pcs. Or lies the problem in the editor itself?

    I guess i should stick to the old fashion quicktags 🙁

Viewing 13 replies - 1 through 13 (of 13 total)
  • you can disable that under options or users…

    ANd i did. 🙂

    But it would be nice if the editor would work properly too.

    Rich editor works well for me FF 1.5 on Windows, so I guess you have some special problem. It’s a bit slow though when you revisit to edit a post. I’ll see the HTML version for a brief moment before it re-renders the post in wysiwyg.

    Yes i noticed that too. But that is not a problem, its a matter of server and conversion speed i guess.

    My problem is when i save the post (new or edited) and the html it creates is so bad it screws up the layout of the page/post and sometimes even the sidebar as tags are not closed properly…

    If you run your pages through the W3C validation service at you will notice some validation errors. It’s like that for my experimental blog too.
    I’m not so sure however, that it has to do with the Rich editor. Maybe something is wrong in the themes we use?

    Nah, i dont think my theme causes the richtext editor to put in 5 open/close tage for bold text and strike tags aftre one another every 2 words. To me it sounds more like a compiling bug.

    Maybe it has something to do with existing pages from wp1.5.2 which are edited in wp2.0. i havent tested this yet but i will next weekend when i have time.

    I’ve had similar issues with the rich-text editor. Great idea, and when it works, it’s wonderful–but it rarely works for me, so I just disabled it. Currently, the thing annoying me most is that there’s no way to put in a single line break with it; it always “skips” a line, double spacing it. Dunno.

    Not trying to solve all your problems 🙁
    but for single line break (aka br) use Shift+Enter in the RTE.

    The Rich Text editor is hard to use. For some reason every time I would add an image, everything after the image would disappear. Definitely some problems (unless I’m an idiot, which is possible) with the Rich Text Editor.

    Please use more respectful language in the future. There are many parents who use WordPress who are extremely offended by use of the word “retarded.” It’s much more than being politically incorrect – it’s hurtful, especially when it’s against our very young children. Slang words for any other minority would not be tolerated here, and this one shouldn’t be either. Thanks so much for your consideration.

    Sorry, I have to disagree.
    There is nothing wrong with the word “retarted” per se. You will find it in every dictionary. It is not a “bad” word that children or anybody should be protected against it. That’s a bit too much…
    On the other hand I fully agree that it shouldn’t be used in relation with persons – even when clinically it would perfectly describe a developmental challenge.

    Words by themselves are never “hurtful”. It’s the people…

    if youre offended by others peoples posts then i think you should not come to forums (or internet at all). If its forbidden it would be filtered out or some guideline would have been set… I saw neither so in my opinion im ‘free’ to use those words in a descent matter.

    Back to topic tho. Ive created a NEW page which was not ‘upgraded’ from wp1.5.2 the problems keep occuring. So i, again, disabled the RTE. Poor me 🙁 I hope this will be fixed soon…

    Using WP2.x: I also tried the ‘Shift+Enter’ solution in the RTE — worked.

    Thanks, moshu!

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Retarded richtext editor’ is closed to new replies.