Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Mateusz Gbiorczyk

    (@mateuszgbiorczyk)

    Hi @jdtravel,

    Thank you for your message.

    What conversion method do you use? GD or Imagick? GD library does not allow this. Please try using Imagick – if your server allows it.

    And then please delete the following line:
    $image->stripImage();

    from file:
    /webp-converter-for-media/trunk/app/Convert/Imagick.php

    If this works and solves your problem, I will issue an update with this functionality.

    Thread Starter JDTravel

    (@jdtravel)

    Hi Mateusz, thank you for your quick reply.
    I’m currently using GD conversion method as Imagick was greyed out. I’ve now enabled Imagick on my server (via whm-cpanel) and the Server configuration in Webp Plugin now reports that Imagick Module is enabled ( Ver 3.4.4) But the Imagick option in Settings is still greyed out.

    I noticed though that WEBP isn’t in the list of supported formats

    • This reply was modified 2 years ago by JDTravel.
    Plugin Author Mateusz Gbiorczyk

    (@mateuszgbiorczyk)

    This means that the Imagick library does not support the WebP format. Please read the FAQ of plugin and the question about technical requirements.

    Thread Starter JDTravel

    (@jdtravel)

    Ok no problem, it isn’t a major issue , was just a nice to have, thank you for looking into this and thanks again for a very useful plugin.
    PS.I’ll see if I can update the imagick server module to the latest version that supports Webp

    • This reply was modified 2 years ago by JDTravel.
Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Retain EXIF Meta Data’ is closed to new replies.