Support » Plugin: Mailchimp for WooCommerce » resync not work (problem updating?)

  • Pau

    (@pzaballos)


    Yesterday I updated the latest version of woocommerce and wordpress. Today when my account of Mailchimp.com appears disconnected of my site!

    When I´m trying to resynchronize the plugin (tab “Sync” > botton “Resync”). Appears a message “Starting the sync process…”after that nothing happens.

    Help!

    ### WordPress Environment ###

    WC Version: 3.0.5
    Log Directory Writable: ✔
    WP Version: 4.7.4
    WP Multisite: –
    WP Memory Limit: 256 MB
    WP Debug Mode: –
    WP Cron: ✔
    Language: es_ES

    ### Server Environment ###

    Server Info: Apache/2.2.24 (Unix) mod_hive/5.5 mod_ssl/2.2.24 OpenSSL/1.0.0-fips mod_auth_passthrough/2.1 mod_bwlimited/1.4 mod_fastcgi/2.4.6 mod_fcgid/2.3.6
    PHP Version: 5.6.30
    PHP Post Max Size: 32 MB
    PHP Time Limit: 600
    PHP Max Input Vars: 1000
    cURL Version: 7.53.0
    OpenSSL/1.0.2k

    SUHOSIN Installed: –
    MySQL Version: 5.6.28
    Max Upload Size: 24 MB
    Default Timezone is UTC: ✔
    fsockopen/cURL: ✔
    SoapClient: ✔
    DOMDocument: ✔
    GZip: ✔
    Multibyte String: ✔
    Remote Post: ✔
    Remote Get: ✔

    ### Database ###

    WC Database Version: 3.0.5
    WC Database Prefix: o3o_
    woocommerce_sessions: ✔
    woocommerce_api_keys: ✔
    woocommerce_attribute_taxonomies: ✔
    woocommerce_downloadable_product_permissions: ✔
    woocommerce_order_items: ✔
    woocommerce_order_itemmeta: ✔
    woocommerce_tax_rates: ✔
    woocommerce_tax_rate_locations: ✔
    woocommerce_shipping_zones: ✔
    woocommerce_shipping_zone_locations: ✔
    woocommerce_shipping_zone_methods: ✔
    woocommerce_payment_tokens: ✔
    woocommerce_payment_tokenmeta: ✔
    MaxMind GeoIP Database: ✔

    ### Security ###

    Secure connection (HTTPS): ✔
    Hide errors from visitors: ✔

    ### Active Plugins (35) ###

    VaultPress: por Automattic – 1.8.8
    Akismet Anti-Spam: por Automattic – 3.3.1
    Ninja Popups: por ArsCode – 4.4.6
    Asesor de Cookies: por Carlos Doral Pérez – 0.24
    Contact Form 7: por Takayuki Miyoshi – 4.7
    DHVC Woocommerce Products Layouts: por Sitesao – 2.2.30
    EWWW Image Optimizer: por Shane Bishop – 3.3.0
    Facebook Likebox Widget & Shortcode: por A WP Life – 0.4.8
    Facebook Reviews Widget: por RichPlugins – 1.2.4
    WPBakery Visual Composer: por Michael M – WPBakery.com – 4.12.1
    Juicer: por Ryan MacInnes – 1.8
    Maintenance Mode: por Lukas Juhas – 2.3.1
    Loco Translate: por Tim Whitlock – 2.0.13
    MailChimp for WooCommerce: por MailChimp – 2.0.0
    Widget de MailChimp: por James Lafferty – 0.8.12
    Ajax Pagination and Infinite Scroll: por Malinky – 2.0.1
    Mashshare Share Buttons: por René Hermenau – 3.4.1
    PixelYourSite PRO: por PixelYourSite – 6.0.4
    Product Catalog Feed Pro by PixelYourSite: por PixelYourSite – 3.1.8
    Scripts-To-Footer: por Joshua David Nelson – 0.6.1
    SF Move Login: por Grégory Viguier – 2.4.3
    SG Optimizer: por SiteGround – 3.3.1
    Simple 301 Redirects: por Scott Nellé – 1.07
    Tidio Chat: por Tidio Ltd. – 3.0.2
    W3 Total Cache: por Frederick Townes – 0.9.5.4
    Product Alerts for WooCommerce: por Bolder Elements – 2.0.2
    WooCommerce Checkout Field Editor: por WooCommerce – 1.5.4
    WooCommerce Stripe Gateway: por WooCommerce – 3.1.7
    WooCommerce Measurement Price Calculator: por SkyVerge – 3.11.3
    WooCommerce Pay for Payment: por Jörn Lund – 1.3.8
    WooCommerce Product SKU Generator: por SkyVerge – 2.3.1
    WooCommerce: por Automattic – 3.0.5
    WooCommerce Helper: por WooCommerce – 1.7.2 – Red habilitado
    WordPress HTTPS: por Mike Ems – 3.3.6
    Yoast SEO: por Equipo Yoast – 4.7

    ### Settings ###

    API Enabled: ✔
    Force SSL: ✔
    Currency: EUR (€)
    Currency Position: right
    Thousand Separator: .
    Decimal Separator: ,
    Number of Decimals: 2
    Taxonomies: Product Types: external (external)
    grouped (grouped)
    simple (simple)
    variable (variable)

    Taxonomies: Product Visibility: exclude-from-catalog (exclude-from-catalog)
    exclude-from-search (exclude-from-search)
    featured (featured)
    outofstock (outofstock)
    rated-1 (rated-1)
    rated-2 (rated-2)
    rated-3 (rated-3)
    rated-4 (rated-4)
    rated-5 (rated-5)

    ### WC Pages ###

    Base de la tienda: ❌ Página sin definir
    Carrito: #5 – /cesta-compra/
    Finalizar compra: #6 – /finalizar-comprar/
    Mi cuenta: ❌ La visibilidad de la página debe ser pública

    ### Theme ###

    Name: The Retailer Child
    Version: 1.0
    Author URL: http:%20//www.getbowtied.com/
    Child Theme: ✔
    Parent Theme Name: The Retailer
    Parent Theme Version: 2.6.2
    Parent Theme Author URL: https://www.getbowtied.com/
    WooCommerce Support: ✔

    ### Templates ###

    Overrides: theretailer/woocommerce/archive-product.php
    theretailer/woocommerce/cart/cart-empty.php
    theretailer/woocommerce/cart/cart-shipping.php
    theretailer/woocommerce/cart/cart-totals.php
    theretailer/woocommerce/cart/cart.php
    theretailer/woocommerce/cart/cross-sells.php
    theretailer/woocommerce/cart/mini-cart.php
    theretailer/woocommerce/content-product.php
    theretailer/woocommerce/content-product_cat.php
    theretailer/woocommerce/content-single-product.php
    theretailer-child/woocommerce/emails/admin-cancelled-order.php
    theretailer-child/woocommerce/emails/admin-new-order.php
    theretailer-child/woocommerce/emails/customer-completed-order.php
    theretailer-child/woocommerce/emails/customer-invoice.php
    theretailer-child/woocommerce/emails/customer-on-hold-order.php
    theretailer-child/woocommerce/emails/customer-processing-order.php
    theretailer-child/woocommerce/emails/customer-refunded-order.php
    theretailer/woocommerce/global/breadcrumb.php
    theretailer/woocommerce/global/quantity-input.php
    theretailer/woocommerce/loop/orderby.php
    theretailer/woocommerce/loop/price.php
    theretailer/woocommerce/loop/result-count.php
    theretailer/woocommerce/myaccount/form-edit-account.php
    theretailer/woocommerce/myaccount/form-login.php
    theretailer/woocommerce/order/form-tracking.php
    theretailer/woocommerce/order/order-details.php
    theretailer/woocommerce/single-product/meta.php
    theretailer/woocommerce/single-product/price.php
    theretailer/woocommerce/single-product/product-image.php
    theretailer/woocommerce/single-product/product-thumbnails.php
    theretailer/woocommerce/single-product/rating.php
    theretailer/woocommerce/single-product/related.php
    theretailer/woocommerce/single-product/review.php
    theretailer/woocommerce/single-product/short-description.php
    theretailer/woocommerce/single-product/tabs/additional-information.php
    theretailer/woocommerce/single-product/tabs/description.php
    theretailer/woocommerce/single-product/tabs/tabs.php
    theretailer/woocommerce/single-product/title.php
    theretailer/woocommerce/single-product/up-sells.php
    theretailer/woocommerce/single-product-reviews.php
    theretailer/woocommerce/single-product.php

    `

    • This topic was modified 5 years ago by Pau.
Viewing 8 replies - 1 through 8 (of 8 total)
  • Thread Starter Pau

    (@pzaballos)

    Another point: i’ve just tried deactivating the rest of plugins,.. not works 🙁

    In my account of mail chimp i can see this:

    Historical API calls by day

    Date/Time Result Throttled? Source IP Method Format Exec Time User Agent Ver Response

    2017-05-03 12:57:26 GMT nope 37.60.226.38 POST /ecommerce/stores/…/pro php 0.03s MailChimp for WooCommerce/2.0.0; WordPress/4.7.4 3.0 The requested resource could not be found.

    2017-05-03 12:57:00 GMT nope 37.60.226.38 DELETE /ecommerce/stores/…/p php 0.037s MailChimp for WooCommerce/2.0.0; WordPress/4.7.4 3.0 The requested resource could not be found.

    • This reply was modified 5 years ago by Pau.
    mcsupport

    (@mcsupport)

    Hi @pzaballos,

    Thank you for reaching out. It looks like your environment meets all of minimum system requirements. To move forward I’d like to rule out any plugin or theme conflicts. In order to do that, could you please temporarily disable all of your active plugins aside from MailChimp for WooCommerce and WooCommerce and revert to a WooCommerce friendly theme such as Bazaar, to see if the behavior persists? If it does not, I would then suggest reverting back to your original theme and then re-activating your other plugins one by one to identify which is causing the conflict. If you could then reach out to the MailChimp support team with the results and a link to this forum post that will allow them to take a look at the incoming API calls and for clues. They can be contacted following the steps outlined here.

    Thanks!

    Pearl

    BACP

    (@bacp)

    The thread author states very clearly that he deactivated all plugins but it still doesn’t work. I had this issue so many times that I left mailchimp altogether. I came back to see if this issue was solved but it seems it’s not…

    Thread Starter Pau

    (@pzaballos)

    I have done this and other tests and I have not reached any clear conclusion.

    The only way I found has been to disable your plugin, activate it and reconfigure it. At that point, It allows me to synchronize again and then it appears as connected in mailchimp.

    Now I´m experiencing other problems. The products appear without image in Mail Chimp and sometimes the connection is lost and I have to repeat the process (deactivate, activate, reconfigure).

    A real annoyance…

    • This reply was modified 5 years ago by Pau.
    • This reply was modified 5 years ago by Pau.
    mcsupport

    (@mcsupport)

    Hey @bacp and @pzaballos,

    @bacp – thanks for joining the thread. It looks like I wrote and posted my response to @pzaballos’s original post before seeing the follow up post. My apologies for missing that! At any rate, the next step would be to reach out to the MailChimp support team following the steps here: http://kb.mailchimp.com/accounts/management/mailchimp-support-options#Contact-Support including all of the requested information. That will allow their support team to take a look at the API calls as they come in and trouble shoot the issues you two are seeing systematically in a clean and organized manner.

    The most common culprits for strange plugin behavior are plugin/extension conflicts, not meeting woocommerce minimum server requirements, or theme conflicts. Since these do not seem to be impacting the functionality for you two, the MailChimp support team will need to take a closer look on their end for clues.

    Thank you!

    Pearl

    BACP

    (@bacp)

    I can’t save the List tab of the plugin. I choose the list I want so sync and change the text of the subscription button but they don’t get saved. After saving the tab it reverts. The initial sync seems to be working (don’t know if it will stay that way). I can’t contact mailchimp support as I’m in a forever free account and have passed the 30 days of free support and I’m not paying before this plugin works properly.

    sorinamzu

    (@sorinamzu)

    Quick follow-up question:
    How do I change the list it syncs to? I’ve selected one, it’s synced. But the option is greyed out, can’t select another list.

    Thanks.

    mcsupport

    (@mcsupport)

    Hey @bacp and @sorinamzu

    Thanks for these follow up questions. We definitely want to address both of these concerns and help out as much as possible. That being said, to make sure we’re staying organized and focused on the original topic at hand for this thread, would you mind making a new post in the Support Forums for MailChimp For WooCommerce? The plugin support forums can be found here: https://wordpress.org/support/plugin/mailchimp-for-woocommerce

    Thanks in advance for creating a new topic for these requests. We’ll keep an eye out there so we can address those questions.

    – Malachite

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘resync not work (problem updating?)’ is closed to new replies.