Support » Plugin: CLUEVO LMS, E-Learning Platform » Restricting URL direct access not working

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author CLUEVO

    (@cluevo)

    Hey tno5,

    not sure what’s going on but when I try your url i only get a 404 page. Your login page seems to be trashed as well.

    Did you already remove the module?

    Greetings,

    the CLUEVO team

    Thread Starter tno5

    (@tno5)

    Plugin Author CLUEVO

    (@cluevo)

    Oh, ok I see it now. What does the settings page say about the state of the security? If it’s active it should say next to the checkbox if the protection is active for the directories ((modules: secured, modules-archive: secured))

    Thread Starter tno5

    (@tno5)

    It says this:

    Enable basic module security (modules can’t be accessed from outside your LMS) (modules: not secured, modules-archive: secured)

    And i have checked this box

    Plugin Author CLUEVO

    (@cluevo)

    hm, ok, can you try toggling it and saving the settings again? Maybe it somehow didn’t take the first time.

    Edit: Ok, I just checked again and it seems like the option currently doesn’t correctly update when it is initially enabled. It should properly enable once you disable it (and save) and then enable it again. It’s because for WordPress the option doesn’t exist when you first save it, so it never gets to the point where it has to create/delete the file that provides the security feature.

    I’ll push another update that should fix this.

    Greetings,

    the CLUEVO team

    • This reply was modified 2 years, 4 months ago by CLUEVO.
    Thread Starter tno5

    (@tno5)

    its not working ๐Ÿ™ toggled it, uninstalled deleted and reinstalled it as well but still doesn’t work. still stays

    Enable basic module security (modules canโ€™t be accessed from outside your LMS) (modules: not secured, modules-archive: secured)

    Thread Starter tno5

    (@tno5)

    you can check here: https://super-axe.myliftersite.com/wp-admin/admin.php?page=cluevo-settings

    username: trial
    pwd: Yv4uQew6zsGcYVeGjzJ8g0

    Plugin Author CLUEVO

    (@cluevo)

    ah ok, please see my edit on the previous post. If you uninstalled the option is deleted again so you’d have to go through the same spiel again.

    I fixed this in the current development version, so if you can confirm that it does indeed work once you enable -> save, disable -> save and then enable/save again I’ll push it.

    I just tried it on a fresh install and it now indeed properly initializes on the first save.

    Edit: I still can’t access your backend, it tries to redirect me to your login page, but your login page seems to be in the recycling bin.

    • This reply was modified 2 years, 4 months ago by CLUEVO.
    Thread Starter tno5

    (@tno5)

    oh okay – thanks got it. Another issue. now the module is not opening. you can check here: https://super-axe.myliftersite.com/new/

    Also you can login and check with the credentials above

    Plugin Author CLUEVO

    (@cluevo)

    The login page still doesn’t work for me, I think you can only access it because you are already logged in.

    Is this a new module or the same as before?

    I can’t tell much just from the frontend, but it looks like your module reports as scorm version 1.1, which we don’t support. Not sure if this is the whole reason, I’d have to see the module manifest file again to double check. If this is indeed the reason, it doesn’t work because your module can’t find a scorm api that provides 1.1 support.

    Thread Starter tno5

    (@tno5)

    I think thats the problem…. you are right. its scorm 1.1 – when i did scorm 2004 it worked great ๐Ÿ™‚ thanks a lot

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Restricting URL direct access not working’ is closed to new replies.