Support » Plugin: Restrict Content » Restricted messages don’t work!

  • delacombo

    (@delacombo)


    Entering messages into the “restricted” text field via the settings does not show on a page that is set to be restricted. So if you have a password set to the page, it doesn’t allow you to say “Please login…” at this other duplicated place, so that you can see the password field to enter this page’s password. I even tried the short code for if not logged in, so a person knows they need to sign in first, so that the system can see the user’s level, and then show another field for the page password. So convoluted.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author mordauk

    (@mordauk)

    Hi @delacombo!

    Are you using the “Password” functionality provided by WordPress itself?

    That feature in WordPress in designed to allow admins to define a password that is required to be entered in order to view the page. That password is not the same password that users would use to log into their account.

    I think you will get the behavior you’re after if you remove the password from the page edit screen and just use Restrict Content to limit access to the page to logged in users.

    Hope that helps! If not, thanks for the feedback anyhow!

    delacombo

    (@delacombo)

    The issue isn’t with the additional password for the page, it’s that when visiting the restricted page, there is no way to show a message that a person needs to login first (to the WordPress login) to see anything. It will only show the page title, no matter what.

    Plugin Author mordauk

    (@mordauk)

    There is an option in Restrict > Settings to define the message shown to users when they view the page without being logged in.

    You can also use [restrict message="This text is shown to users when not logged in"]Content that is hidden[/restrict] inside of the page content.

    If one or the other of those is not working properly, it’s very likely there is some kind of conflict with another plugin on your site or the theme you’re currently using. You can confirm (or deny) this by temporarily activating another theme and/or deactivating other plugins on your site.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Restricted messages don’t work!’ is closed to new replies.