Forums » Plugin: Email Template Designer - WP HTML Mail » Restrict width of message (max-width)?

  • Resolved altimac

    (@altimac)


    Hi, jsut wondering if there is a way to restrict the maximum width of the message to, say, 650px? Most of the emails sent from my site look great, but Wordfence alerts, and a few others, end up showing as wider than the viewport of the email client so you have to scroll to read the message. Thanks for any help you can offer.

Viewing 9 replies - 16 through 24 (of 24 total)
  • Plugin Support Julian

    (@juliangk)

    Hello @altimac,

    Monster Insights is a different issue, the fix was made for FluentCRM only, however, I can have a look at it aswell.

    I would kindly ask you for access to the staging site. Can you please send the details to support(at)codemiq.com?

    Thank you and best regards
    Julian

    Thread Starter altimac

    (@altimac)

    Hi, Julian. Just sent you credentials to our staging site. Hope you can suss out the issue.

    Plugin Support Julian

    (@juliangk)

    Hello @altimac,

    thank you very much for the access. After some testing I found following:

    • First you have to make sure that under the tab in our plugin, “Plugin emails”, the two options “Hide header” and “hide footer” are turned off, and that the option “Use template is turned on”.
    • In the FluentCRM Options, you have to make sure the e-mail template is set to one of the templates that is not “Raw HTML”. Raw HTML will not work with our plugin.
    • If you use Raw HTML, you have to format the entire e-mail yourself, preferably using tables and adding your own styles.

    Best regards
    Julian

    • This reply was modified 1 year, 1 month ago by Julian.
    Thread Starter altimac

    (@altimac)

    Thank you, Julian. I think I only switch to the Raw HTML version to make sure that I have the

    <!-- Sender: FluentCRM -->

    comment included in the HTML so that WP HTML Mail ignores those emails. Are you saying that if I remove those comments and remove the below from functions.php:

    // Prevent WP HTML Mail plugin from modifying FluentCRM emails
    // Just add <!-- Sender: FluentCRM --> to the body of the email templagte
    add_filter( 'haet_mail_use_template', 'customize_template_usage', 10, 2 );
    	function customize_template_usage( $use_template, $mail ) {
    	$string = $mail['message'];
    		if( str_contains($string, 'Sender: FluentCRM') )
    		{
           		return false;
    		}
    	return $use_template;
    }

    that I don’t need to exclude your plugin from FluentCRM emails?

    Plugin Support Julian

    (@juliangk)

    Hello @altimac,

    with the beta you can use our “plugin emails” option to deactivate the template for FluentCRM, you wouldn’t need to use the filter.

    Best regards
    Julian

    Thread Starter altimac

    (@altimac)

    Thanks, Julian. That’s a lot easier than adding filters to functions.php 😉 Just want to confirm, the hide header and hide footer options refer to your plugin’s footer, or the plugin for which you are configuring the settings? In other words, in the FluentCRM settings, am I hiding THEIR header and tooter, or YOUR header and footer?

    Plugin Support Julian

    (@juliangk)

    Hi @altimac,

    the options “hide header” and “hide footer” are refering to our plugin’s header and footer.

    However, in the current implementation of fluent CRM, if you use our plugin for the FluentCRM emails, only the FluentCRM mail template body will be send, the “96” display problem came from the FluentCRM header.

    Best regards
    Julian

    Thread Starter altimac

    (@altimac)

    Got it, thanks, Julian!

    Plugin Support Julian

    (@juliangk)

    @altimac, you are most welcome. Let us know if there is anything else we can help you with!

Viewing 9 replies - 16 through 24 (of 24 total)
  • The topic ‘Restrict width of message (max-width)?’ is closed to new replies.