[resolved] Restore failed -- call to undefined function (4 posts)

  1. TomJohnson
    Posted 9 years ago #

    I tried upgrading to 2.2, but received errors I couldn't resolve. So I tried restoring back to my old version. Before upgrading I backed up my database, and I restored it using these instructions: http://www.tamba2.org.uk/wordpress/restore/

    There isn't a whole lot of info on how to restore a blog after restoring the database. I deleted the appropriate files and reuploaded the 2.1.2 wordpress files.

    However, when I go to my blog, I see this: Fatal error: Call to undefined function: wp() in /home/idrathe1/public_html/wp-blog-header.php on line 16

    I'm at my wits end, having spend the last 2.5 hrs with WordPress. Can anyone provide help to me? Thanks. My blog is at http://idratherbewriting.com

  2. TomJohnson
    Posted 9 years ago #

    Finally got the restore working again. I refreshed the wp-config file from the wp-config-sample file, just copying over the unique database info etc. into the sample file.

    I think the heart of my problem was with the wp-cache plugin.

  3. TomJohnson
    Posted 9 years ago #

    now I have a new problem: strange characters: —

  4. TomJohnson
    Posted 9 years ago #

    Here's the resolution to the strange characters problem:


Topic Closed

This topic has been closed to new replies.

About this Topic