Support » Networking WordPress » REST API : problem

  • Hello,

    I recently discovered in the “site health” tab that REST API is disabled, although I did not do this myself. However, when I check using this URL

    https://rodolphehaller.com/wp-json/

    or this one

    https://rodolphehaller.com/?rest_route=/

    there is no ‘disable’ message as mentioned in several articles, but instead a page of code (see capture below).

    Also, I just installed WPML on the website cited above, and in the requirements it is also mentioned that REST API is disabled. (see capture below)

    How can I check if it is really disabled, and in that case, how can I enable it and fix the problem?

    Thank you for your help!

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Moderator bcworkz

    (@bcworkz)

    The API appears to work from external requests, but the Site Health check is performed by having the server make a HTTPS request to itself (a loopback request). That can fail for any number of reasons, often due to server security configuration. When you expand the REST API disabled error in Site Health, what exactly does the description say?

    It’s likely you’ll need your host to alter their security configuration, but the description under the API disabled error might tell us more about what actually went wrong.

    For a reminder to myself more than anything, the API check is done at WP_Site_Health::get_test_rest_availability().

    Thread Starter cbonargent

    (@cbonargent)

    Thank you for your reply. It says (translated from French) :

    ————————————————
    The REST API encountered an error
    Performance
    The REST API is one way that WordPress or other applications communicate with the server. One example is the editor screen, which relies on it to display and save your posts.

    The REST API request failed due to an error.
    Error: cURL error 35: error:140770FC:SSL routines:SSL23_GET_SERVER_HELLO:unknown protocol (http_request_failed)”
    ————————————————

    Otherwise, I haven’t actually begun the WPML set-up. Maybe the plugin will work—but maybe not. Probably better to know for sure.

    Thanks again for your help.

    Moderator bcworkz

    (@bcworkz)

    cURL error 35 happens when the SSL/TLS handshake fails when trying to establish a HTTPS connection. There is no problem with the SSL certificate since external requests work fine. There are several other possible reasons for failure, they all have to do with server configuration of some sort. Most likely is some sort of security restriction in the firewall or modSecurity. You’ll very likely need your host’s assistance to correct a cURL error 35.

    Thread Starter cbonargent

    (@cbonargent)

    I will look into how to correct this “curl error 35”. It seems like the best place to start is to update SSL protocole and ask our host to update the curl extension.

    Hoping this will work!
    Thank you for this information.

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.