Support » Plugin: Currency Switcher for WooCommerce » REST API not working when plugin enabled

  • Resolved rudolfl

    (@rudolfl)


    Hi,

    Site Health shows:
    REST API encountered an error

    The REST API request failed due to an error.
    Error: cURL error 28: Operation timed out after 10001 milliseconds with 0 bytes received (http_request_failed)

    Error is linked with this plugin. When I disable plugin, error disappears. Enable plugin and error is back.

    Execution time on server is set to 300, memory limit was increased to 512M. Server runs PHP 7.3

    WP: 5.4.2
    WooCommerce 4.2.0
    Currency Switcher: 2.12.1

    Thanks,
    Rudolf

Viewing 4 replies - 1 through 4 (of 4 total)
  • Thread Starter rudolfl

    (@rudolfl)

    I did another test to isolate the problem

    All plugins disabled, except WooCommerce and Currency switcher.
    Running 20/20 theme.

    Problem exists.

    Rudolf

    can confirm fault this on my site.

    Plugin Author WP Wham

    (@wpwham)

    This is a known bug in WordPress. Aside from the Healthcheck message, it does not interfere with the normal functioning of your website.

    The WP Team have a fix slated for version 5.5. We are waiting for WordPress to release the fix.

    If you need further support please open a support ticket. We do not monitor this forum.

    Thread Starter rudolfl

    (@rudolfl)

    Thanks,

    This is actually useful info and with a workaround too.

    Rudolf

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘REST API not working when plugin enabled’ is closed to new replies.