Support » Plugin: Open Graphite » Responsive images and Open Graphite

  • Resolved borajski

    (@borajski)


    Hi,

    I am developing a new wp theme based on Bootstrap4. I have function that put img-fluid to on every image tag. It worked fine until my client hasn’t install OG. After using OG ‘image-fluid’ appeares to be erased. When I unistall OG everything works fine again. For now, the only solution is to put manually ‘image-fluid’ to back code of each new post.
    Where is the problem with OG, and how to fix it?
    Function code is:

    function wpresponse_add_image_class ($class){
    $class .= ‘ img-fluid’;
    return $class;
    }
    add_filter(‘get_image_tag_class’,’wpresponse_add_image_class’);

    Thanks
    Best regards
    SK

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Michael Ott

    (@mikeyott)

    That’s highly unusual, and honestly I can’t think of a single reason for that to happen.

    Open Graphite does not manipulate the images (or image paths) in any way. All it does is add HTML meta tags into the head of the document via the WordPress wp_head() function.

    The only thing I can think of that may solve your problem is to use the Theme output priority setting under the Troubleshooting heading, and see what happens.

    I’d be interested to know if that solves the issue.

    Hi Michael,

    thank you for your advice and efforts. I solved the problem. But, I have to apologize because the problem had nothing with OG. It was just a coincidence, the problem appeared when OG was installed. So I made wrong conclusion.
    Problem was caused by images attached from URL, not from WP media library. I solved it declaring all images responsive in my css file.

    Thank once again!
    Best regards
    SK

    Plugin Author Michael Ott

    (@mikeyott)

    No worries – I’m just glad you got it sorted (and that it was not the fault of the plugin :-P.

    Have a great day!

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.