WordPress.org

Forums

The Support Forums will be in read-only mode for a scheduled maintenance window on 01 September 2016 14:00 UTC - 20:00 UTC. More information.

Suits
Responsive Header Image (8 posts)

  1. dlewis88
    Member
    Posted 2 years ago #

    I have tried every variation of CSS I can think of and still cannot get the header image to be responsive. It cuts off both the right and left and only shows a middle chunk when on both iPhone and iPad devices.

    I noticed the default text header sizes down to become responsive on mobile devices, but the custom image you upload in the theme's header settings does not.

    I'd like to either get the header image to be responsive, or find an easy way to only show the text header when on mobile devices.

    Can anyone help with this???

  2. Andrew Nevins
    Forum moderator
    Posted 2 years ago #

    Let's see the Webpage you're referring to

  3. dlewis88
    Member
    Posted 2 years ago #

  4. Andrew Nevins
    Forum moderator
    Posted 2 years ago #

    Did you try giving it a background size of 100%?

  5. dlewis88
    Member
    Posted 2 years ago #

    yes, i've tried that and it doesn't do anything. just shows up crossed out when i use the "inspect element" tool.

  6. Andrew Nevins
    Forum moderator
    Posted 2 years ago #

    Could you post here the CSS you're using and let us know where you're putting it?

  7. admin2012admin
    Member
    Posted 2 years ago #

    Hello,

    I have an image in the Suits theme custom header that I would like to have auto rezised for each step of responsiveness (full size for desktop, smaller percentage for tablet, smallest for mobile/small screen). Where do I edit the CSS to hit those distinct steps and not just have it resize continuously?

    My site is http://www.herberthouse.com

    Thanks.

  8. oliviaontheriviera
    Member
    Posted 2 years ago #

    I am also having this issue, the header does not adapt to mobile layout moreover I also have an issue whereby on desktop view I have white bits on either side of my header, even though I uploaded an image that fits the suggested theme size. Can anyone help on this? Blog is http://www.oliviaontheriviera.com
    Thanks!

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic