WordPress.org

Support

Support » Themes and Templates » [Resolved] Responsive Child Theme not showing up in Appearance

[Resolved] Responsive Child Theme not showing up in Appearance

  • davidbreedlove
    Member

    @davidbreedlove

    I have added a folder “../themes/responsive-child” and put an edited style.css in it, but … it doesn’t show up in Appearance. This message is at bottom of Appearance page:

    Broken Themes

    The following themes are installed but incomplete. Themes must have a stylesheet and a template.

    Name Description
    Responsive Template is missing.

    Should it matter that there are three domains on this ISP account?
    What am I missing?

Viewing 3 replies - 1 through 3 (of 3 total)
  • WPyogi
    Forum Moderator

    @wpyogi

    Do you have this at the top of the child theme style.css file:

    /*
    Theme Name:     Responsive Child
    Template:       responsive
    */
    @import url("../responsive/style.css");

    After that you should only have changes to the CSS – not a copy of the entire parent file.

    You must also have the Responsive theme still installed but not active.

    The child theme must be activated.

    core-basic
    Blocked

    @core-basic

    Also, make sure the folder is readable. Make sure to chmod it if necessary.

    davidbreedlove
    Member

    @davidbreedlove

    ThanksWPyogi. That did it.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[Resolved] Responsive Child Theme not showing up in Appearance’ is closed to new replies.