Support » Plugin: LiteSpeed Cache » Response Placeholder Keeps Showing Even When Set to OFF

  • Resolved essaund

    (@essaund)


    Hello,

    I want to use LScache Lazy Loading feature. But it forces the responsive placeholder to show even when I haven’t enabled that feature.

    This is happening on two of my websites with different themes. Even when I disable all CSS/JSS options, it still shows not unless I deactivate lazy loading altogether.

    How can I fix it because I don’t want that responsive placeholder to show.

    Regards

    Check Report number: DPEWVSME

    • This topic was modified 2 months, 1 week ago by essaund.
Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Support qtwrk

    (@qtwrk)

    Hi,

    I don’t see any responsive placeholder in your page

    all images are showing as

    <img data-lazyloaded="1" src="data:image/gif;base64,R0lGODdhAQABAPAAAMPDwwAAACwAAAAAAQABAAACAkQBADs=" width="280" height="210" data-src="https://xxx/wp-content/uploads/2019/07/f20-280x210.jpg" class="attachment-pixwell_280x210 size-pixwell_280x210 wp-post-image" alt="" loading="lazy" />

    responsive placeholder will add code like data-placeholder-resp="555x555" into the HTML code

    Best regards,

    Thread Starter essaund

    (@essaund)

    Hello,

    Just open any article on the website and see for yourself. It’s there.

    Or where can I send you a screen recording of the same?

    It’s a gray placeholder placed by LSCache and it matches the color under LSCache settings.

    Once I deactivate Lazy Load on LSCache it disappears.

    I faced the same issue on my main domain with a different theme as well and I stopped using LSCache on that website because if it.

    Regards.

    • This reply was modified 2 months, 1 week ago by essaund.
    • This reply was modified 2 months, 1 week ago by essaund.
    • This reply was modified 2 months, 1 week ago by essaund.
    Plugin Support qtwrk

    (@qtwrk)

    Hi,

    that’s not responsive place holder, that’s normal placeholder

    go page optm -> media setting -> lazyload image , set it OFF will get rid of that

    Best regards,

    Thread Starter essaund

    (@essaund)

    Hello,

    Exactly, you can see it now.

    Turn what off? Lazy Load Images (As I said earlier, turning off lazy loading removes that placeholder).

    I want to use Lazy Load but minus that placeholder showing.

    Also it’s aggressively compressing images and they appear super low quality.

    Regards

    • This reply was modified 2 months, 1 week ago by essaund.
    Plugin Support qtwrk

    (@qtwrk)

    then you can try to set the placeholder to white or transparent

    Thread Starter essaund

    (@essaund)

    How do I set it to transparent?

    But this is a bug that should be fixed. Don’t you think so?

    I remember back in 2019 LSCache Lazy Load feature didn’t have a random placeholder hanging around when activated. I noticed it started showing from one of the updates in 2020.

    I know I can use a different solution for lazy loading. But I don’t want to stuff many plugins when one can handle the same job.

    • This reply was modified 2 months ago by essaund.
    Plugin Support qtwrk

    (@qtwrk)

    I’m sorry , what bug ?

    it is working as it is designed to , the default value is that grey-black placeholder you saw , and in tooltip , it has the value to be used as transparent

    if you read the tooltip below the Basic Image Placeholder , you will see

    Specify a base64 image to be used as a simple placeholder while images finish loading.
    This can be predefined in wp-config.php as well using constant LITESPEED_PLACEHOLDER, with this setting taking priority.
    By default a gray image placeholder data:image/gif;base64,R0lGODdhAQABAPAAAMPDwwAAACwAAAAAAQABAAACAkQBADs= will be used.
    For example, data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7 can be used for a transparent placeholder.

    deewinc

    (@deewinc)

    Hello,

    Thanks for highlighting that.

    Now I get it. I can see it’s working.

    Is there a way I can change the Responsive Placeholder to transparent?

    Regards

    • This reply was modified 2 months ago by deewinc.
    deewinc

    (@deewinc)

    Hello,

    Sorry about that.

    Having a mixed up of accounts.

    The placeholder now is set to transparent.

    Is it possible to set the Responsive Placeholder to transparent too?

    Plugin Support qtwrk

    (@qtwrk)

    sadly no , but you can make it white , it should be close enough effect as transparent

    in color selector , set to 255 255 255

    deewinc

    (@deewinc)

    Hello bro,

    Thanks a lot for helping out.

    It’s now working perfect.

    Regards

    Thread Starter essaund

    (@essaund)

    Hello,

    Is it possible to have a transparent responsive placeholder? Nowadays, themes have a switch that allows visitors to toggle between dark mode and light mode.

    Having the responsive placeholder in one colour messes either mode. Or you can include an additional option for enabling responsive placeholder for themes with dark mode.

Viewing 12 replies - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.