Support » Plugin: Yoast SEO » Response Connection Failure. Error parsing the response to JSON. Yoast SEO

  • Resolved rr2022

    (@rr2022)


    I get this error message when i try to run Yoast SEO optimization. Error parsing the response to JSON. and Response Connection Failure.

    I have done the yoast test plugin reset but that didnt work. can someone please help

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Support Maybellyne

    (@maybellyne)

    Hello @rr2022,

    I am sorry about the error you received when running the SEO data optimization. First, I want to assure you that not performing the optimization process will not affect your site negatively in search results. Additionally, the optimization process will run silently in the background as content on your site is created, modified, or removed.

    The error above is generic and I cannot say specifically what could have caused it. From time to time, we see that other site components could prevent SEO data optimization from running smoothly. Therefore as a first step, we ask you to try the following:

    1. Install the Health Check plugin. The plugin will permit you to perform a conflict check by deactivating plugins and switching themes. Doing so will not affect the SEO of your site, and your visitors will still be able to view your site as usual.
    2. Verify you have the default theme Twenty-Twenty. If not, please install it.
    3. Navigate to WordPress > Tools > Yoast Test
    4. Click on the ‘Reset indexables tables & migrations,’ ‘Reset Prominent words calculation, and ‘Reset Internal link counter’ buttons. After each click, the page will reload to confirm that each reset was successful.
    5. Activate the Troubleshooting Mode (TM) in the Health Check plugin.
    6. In TM, activate only the Yoast SEO plugin and the default theme Twenty-Twenty.
    7. Rerun the SEO data optimization.
    8. Deactivate the Troubleshooting Mode in the Health Check plugin.

    In this way, was the SEO data optimization completed? Do let us know.

    Thread Starter rr2022

    (@rr2022)

    thank you. I’m away this week. I will try this next week and let you know how i go. please dont close this ticket. ta

    Thread Starter rr2022

    (@rr2022)

    thank you. simply switching to the Twenty-Twenty theme worked.

    Plugin Support devnihil

    (@devnihil)

    @rr2022 Thanks for confirming that switching the theme resolved the issue.

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.