WordPress.org

Forums

Polylang
[resolved] Responisve - Polylang tiny bug (5 posts)

  1. Ulrich
    Member
    Posted 2 years ago #

    Hi Chouby,

    I came across a small bug.
    To recreate the bug
    create a blank install
    install Responsive theme and Polylang
    add two languages
    Then access the home page, the default language will show the custom homepage but the homepage for the second language will display a 404 error.

    http://polylang.grappler.tk/en/
    http://polylang.grappler.tk/de/

    Solution - translate the Hello World! post or delete it permanently.

    Cause - The reason is that themes with custom home pages have the reading settings set to latest posts but display their own content.

    P.s. This problem should be solved for Responsive in version 1.9 but themes like Pitch still have this problem.

    Ulrich

    http://wordpress.org/extend/plugins/polylang/

  2. Chouby
    Member
    Plugin Author

    Posted 2 years ago #

    Strange... I made the test with Polylang 1.0.1 and Responsive 1.8.7 and did not reproduce this.

    Why deleting "Hello World" on the English side would help on the translated home page?

  3. Ulrich
    Member
    Posted 2 years ago #

    I meant the initial posts that is included in a fresh install. I just realized something. The initial post had no language set to it.

    This is one of those set up bugs. I think if the initial post is only trashed and has no language set to it then the red text asking to set all posts without language set to them is not activated in the Poly lang settings.

    Ulrich

  4. Chouby
    Member
    Plugin Author

    Posted 2 years ago #

    Yes I understood what you meant, but could not reproduce as is. However, I reproduce the same if I de-activate / re-activate the plugin (rewrite rules are not flushed). Could it be what you did?

    The red option should be present at least for 'uncategorized'

  5. Ulrich
    Member
    Posted 2 years ago #

    The problem is this. There is post with no language in the trash.
    http://pix.am/A6kh.png
    There is also no option in the plugin settings to set it to the default language.
    http://pix.am/cFVH.png

    I am not sure what the problem is because I wanted to make a screencast but then it worked. There might be nothing you can do.

    The solution to the problem would be to delete any posts in the trash and resave the permalinks.

    Ulrich

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Polylang
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.