Support » Fixing WordPress » #respond not working – have tried editing comments.php

  • Resolved Mabel Figworthy

    (@mabel-figworthy)


    Hello, I have written several websites but am new to WordPress. I’m setting up a blog on my own website. The blog URL is http://mabelfigworthy.co.uk/fof/

    The theme used is Toolbox, but modified to make it blend in with the rest of my site.
    I have one active plugin, Subscribe2. I have tried de-activating it but that didn’t make a difference to the problem below.

    When I try to leave a comment by clicking on “Leave a comment”, the URL goes to something like http://mabelfigworthy.co.uk/fof/2011/12/24#respond
    and one of two things happens:
    1) If I started on the home page and clicked on “Leave a comment” on any of the posts, it takes me to the page for that post with #respond added, shows the top of the page, and no comment box anywhere.
    2) If I started on the page of an individual post, it adds #respond to the URL but otherwise nothing happens — I stay where I was on the page and there is no comment box.

    I searched for this problem and someone suggested that the comments.php file might not have anything marked id="respond" so I looked in that file in Appearance > Editor and found that indeed it didn’t.

    That presumably explains the behaviour when I click on “Leave a comment”, but I don’t know how to solve it. I found <div id="comments"> and tried changing that to <div id="respond"> but that made no difference.

    Also, the comment box is never visible. I searched for that too, and someone suggested going to “Screen options” but when I do it only gives me the options to “Show on Screen” Author and In Response To, and how many comments to show on screen.

    I would be grateful if anyone could help me show the comment box, and make “Leave a comment” work!

Viewing 6 replies - 1 through 6 (of 6 total)
  • Moderator keesiemeijer

    (@keesiemeijer)

    The links are going to a date based archive page. Which probably uses the theme template file archive.php. Usually the comment box is only available on single post pages (single.php). Did you modify the output of the permalinks in the theme?

    Michael

    (@alchymyth)

    Forum Moderator

    try to reset the permalinks to default;
    http://codex.wordpress.org/Using_Permalinks

    there seems to be something with the links that always links to an archive page, instead of the single post.

    Mabel Figworthy

    (@mabel-figworthy)

    Thanks, I wasn’t aware it would only appear on the single post pages.
    In single.php there is:

    <?php
    // If comments are open or we have at least one comment, load up the comment template
    if ( comments_open() || ‘0’ != get_comments_number() )
    comments_template( ”, true );
    ?>

    but I’m not sure what this is loading. Would this load comments.php?

    Yes, I’m using Custom Settings for the permalinks, /%year%/%monthnum%/%day%
    Could this cause the problem?

    PS and OT — Bent u Vlaams?

    Mabel Figworthy

    (@mabel-figworthy)

    I posted before reading your reply, alchymyth — I set the Permalinks back to default and now it works, thanks!

    Now I have another question, though…

    Is there a way to have my custom setting and have working comments?

    Moderator keesiemeijer

    (@keesiemeijer)

    Try setting it to /%year%/%monthnum%/%day%/%postname%/

    Mabel Figworthy

    (@mabel-figworthy)

    Works a treat, thank you both so much!

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘#respond not working – have tried editing comments.php’ is closed to new replies.