[resolved] Reset password key not working in 2.7 (5 posts)

  1. ninnypants
    Posted 7 years ago #

    Our confrence using a WordPress install to allow users to register and vote for which conference presentations they would like to see. We have run into a problem though. A user has registered and forgotten their password but when they tried to reset their password it tells them that the key is invalid.

    I tested this and no matter what I've tried I cannot fix this problem. Up until today we were using a 2.5 version, but in my reading I found that this was a bug in the 2.5 versions and upgraded our install.

    Does anyone have an idea of what might be going on?

  2. In the database, look at the wp_users table. Look at the contents of the activation_key column. Clear that column, then try it again. You'll need to get another reset email.

  3. ninnypants
    Posted 7 years ago #

    This is for every member correct?

  4. Yes.

    There was a bug around ~2.5 that would incorrectly set the key to a non-functioning one. This was fixed, but if the old key was still there, it wouldn't generate a new one. Clearing the keys should fix the issue.

    Actually, the upgrade process should clear the keys anyway, but it's worth a shot.

  5. ninnypants
    Posted 7 years ago #

    It worked

Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.