Support » Plugin: Amazon AWS CDN » Reset Configuration IS NOT WORKING

  • Resolved abdelrahman

    (@abdelrahman)


    Hello,

    The plugin is working fine but unfortunately, when I tried to reset configuration nothing work!

    I tried to deactivate and activate … same issue
    I tried to DELETE the plugin and install it again .. still same issue

    How can I reset the configuration? I want to use different access key

    Thank you

Viewing 15 replies - 1 through 15 (of 19 total)
  • Plugin Author luckychingi

    (@luckychingi)

    Hello @abdelrahman
    What does the Reset Configuration button do?
    When you click the Create AWS Distribution. button, it checks if the file <yourdomainname>.txt exists in the upload folder.
    This stops the plugin from sending a duplicate request to Amazon (which will be declined anyway).
    The Reset Configuration button only deletes this file
    The CDN setup does not rely on this file.

    Have you tried overwriting the Access Key Id and/or Secret Key

    It should reset the configuration so I can use access key / secret key,

    where’s the .txt file?

    I’m stuck here

    https://i.imgur.com/58NUCNA.png

    Thanks for your response!

    Plugin Author luckychingi

    (@luckychingi)

    When you click the Reset Configuration button and refresh the page, it will show the options to add the Access Key Id and/or Secret Key

    I tried and nothing happens!, I tried even remove it and install it again, I inspect it and nothing on the console.

    There’s any caching in the site even

    I disabled cloudfront and access keys from AWS and still nothing !

    Plugin Author luckychingi

    (@luckychingi)

    The txt file is in the upload folder of your website. Can you check if <domainname>/.txt exists there?

    Note: Replace the <domainame> with your domain

    Yep, It was there, after deleting it, the problem solved
    so what exactly stops this file from deleting? after pressing on reset configuration? can u check it? maybe it’s a bug

    Thanks a lot!!!!

    Plugin Author luckychingi

    (@luckychingi)

    Thanks for the update @abdelrahman

    I’ll check why the file didnt get deleted.

    Plugin Author luckychingi

    (@luckychingi)

    Hello @abdelrahman

    The Reset Configuration button has been fixed.

    Thanks

    Hi Lucky,

    Sorry to open the case again but I notice after I delete the file and reinstall the plugin again “without” entering the access key, somehow the website still reading the CloudFront!

    https://i.imgur.com/pTwq9M3.png

    If I delete the plugin, all works fine, just reinstall the plugin everything goes back somehow it’s still connected even after removing the file!

    I entered the access & secret key and reset the configuration but still! the same issue

    https://i.imgur.com/rqEwrtw.png

    Another question, Is it safe to leave a text file like this having the codes in uploads/ directory?

    It’s open to the public, anyone can guess and open it and take AWS info from it…

    I think it’s better if you write a code to change the “name” to something random like code and hide the domain name in the file itself

    do u have any information in the DB? After resetting the configuration, the style still using the CloudFront, I have to DELETE the plugin to be sure that CDN is not enabled!

    The TXT file already deleted btw after pressing the button but in the “view source” I can still see CloudFront 🙁

    • This reply was modified 6 months, 1 week ago by abdelrahman.
    • This reply was modified 6 months, 1 week ago by abdelrahman.

    I have another question, do u have any idea what causes this?

    https://i.imgur.com/eGWjXGt.png

    Plugin Author luckychingi

    (@luckychingi)

    Hello @abdelrahman

    No worries, I am happy to help.

    The plugin has an option to Disable CDN, use that to disable AWS CDN URLs.
    Use Reset if you plan to change the Access ID and Secret Key.

    The txt file does not hold any private information, here’s what is in wpadmin.ca.txt file on
    https://wpadmin.ca/wp-content/uploads/wpadmin.ca.txt

    <div class='alert alert-success'><p>Successfully created Cloudfront Distribution with ID # <awsid>E1IP74ZE6QJ307</awsid><br><b>IMP: Before performing the below mentioned steps</b><ol><li>Confirm that the status of the the <i>CloudFront Distribution</i> is <b>Deployed</b> in AWS Console</li><li>Ensure that you have modified the DNS (If you plan to use cdn.wpadmin.ca)</li></ol><hr><p>In the <U>CDN DOMAIN / CNAME</U> box</p><p>Add <a class=retval href='JavaScript:void(0);'><b>d2e1hefq4yjysd.cloudfront.net</b></a></p><p>OR<p>Add <a class=retval href='JavaScript:void(0);'><B>cdn.wpadmin.ca</B></a><br>[you will have to add a CNAME entry in your DNS pointing <B>cdn.wpadmin.ca</B> to <b><awsdomain>d2e1hefq4yjysd.cloudfront.net</awsdomain></b>]<wpa_notice>Note: <b>d2e1hefq4yjysd.cloudfront.net</b> points to <b>wpadmin.ca</b></wpa_notice></div>

    I’ll take your suggestion and hide the file in someway.

    The Cloudfront Domain name is stored in the database and the howto explains the steps for different scenarios.

    The icons are blocked because of CORS policy
    You can modify the rule by following this article
    or
    by clicking Stylesheets under Do Not Load These File Types From CDN
    or
    add this file to the exclude list
    https://gulfinsuranceltd.com/wp-content/themes/scalia/css/widgets.css

    I excluded them and disabled stylesheet from the plugin but they still load
    https://i.imgur.com/ebvMPxX.png
    https://i.imgur.com/QIhzUM7.png

    I added
    <FilesMatch “\.(ttf|ttc|otf|eot|woff|woff2|font.css)$”>
    <IfModule mod_headers.c>
    Header add Access-Control-Allow-Origin “*”
    Header set Access-Control-Allow-Origin “*”
    </IfModule>
    </FilesMatch>

    in .htaccess and

    https://i.imgur.com/5zHqCMn.png

    I enabled development mode in cloudflare and purge the cache

    what else should I do ? 😀

    Plugin Author luckychingi

    (@luckychingi)

    My Bad!

    The icons are loaded from this file
    https://d49moswxjox9d.cloudfront.net/wp-content/themes/scalia/css/icons.css
    Add this to the exclude list please.

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘Reset Configuration IS NOT WORKING’ is closed to new replies.