Support » Plugin: ATUM Inventory Management for WooCommerce » Reserved stock not removed from the current stock

  • Resolved coraliesavonneriekesia

    (@coraliesavonneriekesia)


    Hi,

    I created an inventory log to put part of my current stock as reserved stock.

    I remember that, a couple of months ago (in December), the reserved stock was removed from the current stock, so that the number of items available was adjusted to the amount of stock I had put aside in the reserved stock.

    However, now it does not happen anymore, and the available stock does not change according to the amount of items placed in the reserved stock.

    Inventory log is pending, plugin and WooCommerce are up-to-date.

    Do you know why it suddenly does not work anymore ? Is this due to a bug in the plugin ?

    Thanks

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Salva Machi

    (@salvamb)

    Hi @coraliesavonneriekesia

    Sorry but the Inventory Logs never changed stocks automatically. Not sure why are you remembering this because it never happened 🙂
    The Inventory Logs have buttons to Increase/Decrease the stocks manually for the selected items.
    On the other hand, Purchase Orders works differently. These work in the same way as the WooCommerce orders but adding the stock instead of reducing it. So when they are marked as “received”, the stock is added automatically.

    Best Regards,
    Salva.

    Thread Starter coraliesavonneriekesia

    (@coraliesavonneriekesia)

    Hi Salva,

    Thanks for your reply. Maybe I was not clear in how I explained my issue 🙈

    On this page : https://forum.stockmanagementlabs.com/d/12-reserved-stock, it is written ” You can create a Reserved Stock inventory log if you want to remove stock from part of your active inventory.”

    Well, that’s what is actually not working for me. Wether I have reserved stocks or not, nothing changes on my active inventory.

    For instance, I have 100 items in stock, when I make a reserved inventory log to place 10 items on the reserved stock, my item in stock remain at 100 instead of dropping to 90.

    From the article I linked above, that’s how I understand Reserved stock inventory logs are supposed to work, isn’t it ?

    Plugin Author Salva Machi

    (@salvamb)

    Hi @coraliesavonneriekesia

    I’ve just read that article and I see there are things that could be explained better. We’ll change it to be more clear.
    But this article doesn’t say that the product’s stock is changed automatically. What it says is that the “Reserved Stock” column in Stock Central is adjusted accordingly. But to change the product’s stock, you must do it manually.
    You have more info about it in this other article:

    https://forum.stockmanagementlabs.com/d/560-increase-or-reduce-the-stock-from-an-inventory-log

    Best Regards,
    Salva.

    Thread Starter coraliesavonneriekesia

    (@coraliesavonneriekesia)

    Hi Salva,

    Thanks, I do not know why I saw it working in December then 😬🙈 Thanks a lot for sharing the article, I did not come across it and it’s just the missing piece I was looking for !

    Best regards,
    Coralie

    Plugin Author Salva Machi

    (@salvamb)

    You’re welcome 😉

    Thread Starter coraliesavonneriekesia

    (@coraliesavonneriekesia)

    Hi Salva,

    I’m coming back here because I have a new issue with the reserved stock from my log. The “Reserved Stock” column in Stock Central doesn’t change as my inventory log changes.

    I tried a couple of things, including changing the log type to “lost in post”. When I do so, only one of my products changes to “reserved stock : 0 lost in post: xx”. All the other products just do not update somehow. Marking the log complete does just work on this same item but does not affect the reserved stock numbers in Stock Central.

    Do you have any idea where the problem might come from and how I could solve it ?

    Plugin Support andrearebel1

    (@andrearebel1)

    Hi @coraliesavonneriekesia

    Sorry for the delayed answer. I’ve just tested it on my staging site and I was able to reproduce it. So we found a bug here.

    We are going to investigate it and it will be fixed in the next version release.

    Best Regards,

    Andrea.

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.