Rescuing my blog title for browser tabs. (6 posts)

  1. seedubb
    Posted 5 years ago #


    After reading endless forum posts on replacing your blog's title & description with your own image, it dawned on me in the night and I awoke to discover I could 'hide' my title/description off the viewable page and in its place, use the same div class it was using previously to sit my image in there.

    So, using a -750 margin, my text is now no longer visible and my image sits where I want it to, remaining linkable to my blog's home page.

    My reason for wanting to keep my title instead of removing it was so the blog's name remains in the browser's tabs and top window bars. This has reverted back to the URL instead though, and so although I achieved the look I wanted, there was no point!

    Also, whilst checking it visually in other browsers (firefox & explorer) the image in the header has an unsightly blue border around it! Not nice.
    I use Chrome as my default browser. Any ideas where this blue bugger's come from?

    I would appreciate any advice on getting back the display of my blog title in browser tabs, and removing this blue border!


    Many thanks

  2. Joey Kudish
    Posted 5 years ago #

    Hi seedubb,

    For your first question; for the title to appear in the tabs or main window of the browser, double-check that you something resembling this in your header.php file in your theme, within the <head>:

    <title><?php wp_title(); ?></title>

    that's the tag that generates the pretty titles...

    For your second question, add the following line of css in your styles.css file (in your theme):

    a img {border: 0;}

    Good luck!

  3. seedubb
    Posted 5 years ago #

    Thanks jkudish!

    Both codes worked a treat!

    Although there is an underscore showing before my blog's name now, if I remove the name from in Settings there is still an underscore. I'll take a look into the code for a stray _


  4. seedubb
    Posted 5 years ago #

    Hmm, I deactivated an SEO plugin I had installed today (in an attempt to add a page title) and the blog name disappears again.

    I activate the plugin, and the name comes back with the underscore again.

    I've deleted the name field in the SEO plugin's settings. It is 'Last WordPress SEO Plugin'

  5. seedubb
    Posted 5 years ago #

    Anyone got any ideas how I can get my title back for my site, whilst not using this 'Last WordPress Seo Plugin'?

  6. Joey Kudish
    Posted 5 years ago #

    Hi Seedubb,

    You can include your blog name in the title with this code:

    <title><?php bloginfo('name'); ?> <?php wp_title(); ?></title>

    More info on the topic here: http://codex.wordpress.org/Function_Reference/wp_title


Topic Closed

This topic has been closed to new replies.

About this Topic