Support » Plugin: Awesome Social Icons » Requires 4.3 WP_Widget

  • Resolved TheHandOfCod

    (@chrisodell)


    The plugin brings up a warning about the WP_Widget constructor being deprecated in 4.3 when WP_DEBUG is set to true.

    Changed awesomesocial.php on line 39 to
    ‘PARENT::__construct(‘AwesomeSocial’, ‘Awesome Social Icons’, $widget_ops);’ to fix it.

    Cheers.

    Chris

    https://wordpress.org/plugins/awesome-social-icons/

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Daniyal Ahmed (a11n)

    (@daniyalahmedk)

    Hey
    Thank you for letting me know this fix. I will surely update this plugin.

    Plugin Author Daniyal Ahmed (a11n)

    (@daniyalahmedk)

    Thank you – Plugin is updated and now supporting WordPress 4.3.

    Line you have mentioned have “PARENT” in capital which could cause Fatal Error. Please use in small caps.

    Thanks.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Requires 4.3 WP_Widget’ is closed to new replies.