Support » Plugin: Quiz And Survey Master - Best Quiz, Exam and Survey Plugin for WordPress » “Required question” : doesn’t work

  • Hello,

    I don’t understand : I have a quiz with 10 horizontal multiple choice questions.

    Each question is checked as ‘required’.

    But when the quiz runs, the user is still allowed to proceed even if he / she doesn’t answer to some question.

    Why is it so ?

    Adren

    The page I need help with: [log in to see the link]

Viewing 9 replies - 1 through 9 (of 9 total)
  • Thread Starter adrenmaths

    (@adrenmaths)

    1°) Here is a partial (possible) answer to my own question …

    Maybe the devs have considered that in a multiple answers quiz, the user could choose to leave each answer unchecked. If so, it’s clear that the ‘required’ button should have no effect.

    Is it the case ?

    2°) In the case of a horizontal multiple choice, where each question is tagged as required, I noticed the following problem :

    –> in my MacOS environment, the user is free to jump to the next question (without the obligation to check one of the proposed answers : this not the expected behaviour)

    –> in a Windows environment, the behaviour is OK … and for the SAME quiz !!

    Is it a known problem ? Is there something I can do at my level to bypass this problem ?

    Thank you for your time.

    Adren

    Plugin Support expresstechsupport

    (@expresstechsupport)

    Hi @adrenmaths,

    The Required field must work for all the questions in the quiz. I clicked on the link provided by you but it said “Oops, this page does not exist!”

    Kindly provide me the quiz link so that I can check the issue.

    Kind regards,
    Kriti

    Thread Starter adrenmaths

    (@adrenmaths)

    Plugin Support expresstechsupport

    (@expresstechsupport)

    Hi @adrenmaths,

    Yes, I am noticing the issue on your quiz. I am able the proceed to the next question even if the answer is not selected.

    I created a similar quiz on my staging but I am not able to replicate the issue on my staging.

    So for further troubleshooting I request you to kindly share the issue at here as well https://quizandsurveymaster.com/contact-support/

    Kind regards,
    Kriti

    sarahsophie

    (@sarahsophie)

    Same issue in Mac Firefox. Android Works perfect.

    Thread Starter adrenmaths

    (@adrenmaths)

    The quiz that didn’t work was one of the very first ones that I wrote.

    I think that maybe I did some newbie wrong manipulation …

    So I decided to delete that quiz and to rewrite it (by duplicating a recent one that didn’t show that problem) … and it worked.

    In short : I don’t understand what happened, but now it’s ok.

    sarahsophie

    (@sarahsophie)

    I have open the quiz in a private Window in Firefox/Mac. It works perfectly.

    I log out WordPress in a non private Window in Firefox/Mac. It doesn’t Work.

    Thread Starter adrenmaths

    (@adrenmaths)

    I would like to add something regarding this problem.

    Maybe the following hint can be helpful to the dev team.

    I am talking about a horizontal multiple choice quiz.

    I noticed that when checking a question as “required”, saving the question, then unchecking it and saving again, that question still appears in the sidebar as checked.

    There seems to be some issue with the required / not required property …

    Adren

    Plugin Support expresstechsupport

    (@expresstechsupport)

    Hi @adrenmaths,

    Regarding the following issue

    I am talking about a horizontal multiple choice quiz.

    I noticed that when checking a question as “required”, saving the question, then unchecking it and saving again, that question still appears in the sidebar as checked.

    I just checked this setting on my staging and I am not experiencing this issue at my staging.

    Apologies for the inconvenience, can you please check for plugin or theme conflict on your website? The fastest way to rule out a conflict is to deactivate all plugins and switch to a standard theme like Twenty Twenty. If this resolves the issue, you have a conflict and should activate one plugin at a time until you locate the conflict. Finally, after all plugins are active, switch to your theme. This will narrow down the conflict to a specific plugin or a theme conflict.

    If this does not resolve the issue then kindly share the issue at here as well for further troubleshooting https://quizandsurveymaster.com/contact-support/

    Kind regards,
    Kriti

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.