That would imply that it would not be really necessary to update
It’s good for security to update, but you’re not going to miss out on any bugfix or feature in the
3.0.1release by not updating.
so you are saying that nothing changed in the actual plugin?
I browsed the code and looked at the diffs I see nothing that made an update necessary 🙂
But maybe I am not looking hard enough…
Yeah, you didn’t miss anything 😊
Security is the only reason to update to PHP
8.1, and therefore update to Genesis Blocks
There’s no feature or bugfix in GB
3.0.1that you’ll miss out on.
Would have made sense if WordPress would require 8.1.
Also the bump from 7.1. to 8.1 skips 7.4 which is still wide spread…
I use Genesis since the first release and have many sites set to auto update because I trust Genesis and components not to break the sites.
That now results into getting quite a few emails:
Genesis Blocks (3.0.0 -> 3.0.1):
Error: incompatible php required version
I think you might reconsider releasing updates like these until there are genuine functional changes. Sites that were build many years ago with the right components are quite safe on 7.4 when WordPress etc are maintained.
But hey, that’s just me.
I think you might reconsider releasing updates like these until there are genuine functional changes.
Thanks for your ideas, I’ll keep this in mind.
…because I trust Genesis and components not to break the sites.
Oh shoot, so this broke your sites? Sorry, I didn’t realize that.
I thought it just meant your sites couldn’t update to Genesis Blocks
I’m kinda missing the point why 8.1 is made mandatory now if there are no hard requirements. Yes, 8.1 is better than 7.4 or 8.0 in terms of security, but there are so many sites still running on those two that it doesn’t make sense to release an update limiting to only sites on 8.1 or higher.
Because we’ll still see that we have a plugin update waiting for us, but we can’t process it.
Since according to WordPress, the minimum requirement is PHP 7.4, Hostgator is telling me to get lost for my shared hosted site. If Genesis is done supporting me, maybe it’s time to update to a FSE theme
Thanks @devries for summing it up : “missing the point why 8.1 is made mandatory now if there are no hard requirements.” And also pointing out the 8.0.
People using autoupdate mechanisms wil now have to manualy make an exception for the plugin, which can then result in overseeing a real update in a later stage.
I don’t know how you can withdraw or correct this in the plugin, but if you can you should.
The main reason for the update here is because CURL has a vulnerability with the lower bundled versions of PHP, and we want to not recommend people use insecure versions of PHP. If you prefer to keep using an old version of PHP, you can also continue using an old version of Genesis Blocks. WordPress will block the update until your PHP version is updated.
I understand it’s confusing to have a minimum PHP version bump with no functional changes in our plugin. Ideally, I agree with what you are saying.
But this change is less about about functional changes in Genesis Blocks, and more about being compliant with security upgrades. My apologies for any frustration.
We have decided to revert this change for now. An update will be going out later today. Thanks for the feedback all!
CURL has a vulnerability with the lower bundled versions of PHP
Glad you’re reverting this change as blocking folks from updating to your latest version is never going to help you achieve that goal.
- You must be logged in to reply to this topic.