• Hello!

    I have created the catalog and run some ads and the facebook diagnossis displays this error:

    Required parameter content_type is missing from more than 20% of AddToCart events in the last day

    What may be the problem and how can it be fixed?

    Best Regards,
    Daniel M

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author PixelYourSite

    (@pixelyoursite)

    Hi,

    I suspect you have some manually configured add to cart events, because our default event will always have content_type.

    Facebook will tell you on what URLs that error happens, so start by checking them with the Pixel Helper Chrome extension. Do you see any AddToCart event that is missing content_type? If yes, what is firing that event?

    • This reply was modified 3 months, 2 weeks ago by  PixelYourSite.

    Hello There!

    Problem still persists even after your new update. Facebook does not tell me which URLs are affected, it only displays these 2 errors :

    Missing content_type parameter from “AddToCart” XXXX’s Pixel
    Missing content_type parameter from “Purchase” in XXXX’s Pixel

    . I have fired the pixel on multiple products and all of them had the content_type parameter. I do not have any other manually configured atc events neither another plugin installed. What could cause this issue?

    Best Regards,
    Daniel M

    • This reply was modified 1 month, 4 weeks ago by  danielm0608.
    Plugin Author PixelYourSite

    (@pixelyoursite)

    Facebook is usually showing the URLs where the problematic events are fired.

    Go inside your Product Catalog, click on Events Data Sources (left side menu), and click on the event’s tab (AddToCart or Purchase, in this case). You should see a table containing the URLs.

    If you didn’t configured any custom events from our Events tab, I suspect there are older implementations of the code firing those events. Did you have the code implemented before our plugin was installed? If yes, is it completely removed?

    No URL’s are listed on Events Data Sources, just those 2 errors with no URLs. I had the pixel installed with another plugin before, i have checked all the products on my website with Pixel Helper and the pixel is fired only by Pixelyoursite plugin. On the “Events” tab i have General Events switched ON and also the woocommerce set-up switched ON, is this ok?

    Plugin Author PixelYourSite

    (@pixelyoursite)

    There is probably some code left from the old install triggering those events, but I can’t really tell.

    As a last suggestion, you can check inside Facebook Analytics, events debugging. Select the AddToCart event and look for an event that doesn’t have the “content_type” parameter. You should be able to see it’s URL, if I’m not wrong.

    Sorry, but there isn’t much I can do to help!

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.