Support » Plugin: Smart Grid-Layout Design for Contact Form 7 » Required fields not working when using ‘CF7 Smart Grid Design Extension’

  • Resolved DoubleG

    (@doubleg)


    I have been successfully using the ‘CF7 Smart Grid Design Extension’ plugin with Contact Form 7 for a few years now. However, I’ve just noticed that the required field function is no longer working & as a result people can submit the form without filling in any of the fields!

    When I deactivate the ‘CF7 Smart Grid Design Extension’ plugin, the Required Fields function works again! However, I need to use this plugin as that facilitates dynamic drop down lists within the form.

    Has anybody else noticed this problem and if so what can be done to get the required fields function to work correctly again! Is it a recent update that has caused this to happen?

    I’m using:
    Wordpress version: 6.0
    Contact Form 7 version: 5.6
    CF7 Smart Grid Design Extension version: 4.13.0

    The page I need help with: [log in to see the link]

Viewing 15 replies - 16 through 30 (of 46 total)
  • Plugin Author Aurovrata Venet

    (@aurovrata)

    I’m originally from Germany but moved to the Irish west coast (near Galway) 15-ish years ago. So definitely, if you are in the area: shout!

    beautiful country! We were there with my wife for our honeymoon trip back in 2018. We want to visit again, so hopefully we can catch up for a pint of Guinness 🙂

    Absolutely! I’d be delighted 😉

    Plugin Author Aurovrata Venet

    (@aurovrata)

    Great, do reach out on “vrata at syllogic dot in” so we can connect

    Thread Starter DoubleG

    (@doubleg)

    Sorry, but I’m so confused by all the posts over the last couple of days.

    Hi @aurovrata , would you be able to tell me whether you can look into the original question in this string regarding the required field function no longer working since version 4.13 and how this issue can be fixed?

    Any update on this would be most appreciated

    thanks

    Plugin Author Aurovrata Venet

    (@aurovrata)

    I am looking at it as I write. It’s not straightforward as CF7 had completely change the validation process requiring a re-think of what my plugin was doing.

    I hope to get a fix this week.

    For now please use the last version of CF7 5.5.x as instructed here.

    I will notify you in this thread once the fix is released

    That’s strange – I just noticed that the field validation IS working with the latest version of CF7 and CF7 Grid, but only if a conditional group is triggered. You can try it at http://www.bromleysymphony.org/contact (leave the name field blank but select “I would like to join…”).

    I’m not sure this information will help, but I thought I’d mention it anyway, because it surprised me. I can’t find any way to attach a screenshot here, sorry.

    I tried but it didn’t work for me – the fields got marked as “This field is required” but the message was still sent – even with the “I would…” checkbox ticked.

    https://ibb.co/JQy1VdZ

    Once sent the checkbox was reset – thus it’s not ticked in the screenshot.

    Thread Starter DoubleG

    (@doubleg)

    Many thanks for your message @aurovrata – your hard work is much appreciated – best of luck with solving the issue.

    Good point, I meant that at least the warning is shown (which it isn’t otherwise) but you’re correct that the submission is still accepted when it shouldn’t be. (And thanks for the screenshot!)

    Plugin Author Aurovrata Venet

    (@aurovrata)

    Here is a quick update on this issue. I attempted a fix last w.e. which did not work due to the lack of extensibility/reusability of the CF7 code.

    You can read up about my progress here.

    The good news is that I now have a clear idea how to fix this, and should be able to release a fix by the end of this week.

    Your efforts are greatly appreciated and from my point of view there’s no rush, this issue is not causing serious practical problems and I’d rather it worked reliably. This plugin is precious because it’s a key part of the jigsaw that allows complex forms to be built in WordPress without coding or an annual fee. (Depending on your definition of “complex” of course, which in my case includes CiviCRM interworking.)

    Totally agree with Phil here! And I’m sorry for you Aurovrata that it’s not more straight forward and is more hassle than expected. I’m delighted that you managed to find a solution – good luck! No rush here either, take all the time you need 😉

    Thread Starter DoubleG

    (@doubleg)

    Great news @aurovrata. Much appreciated

    Hi,
    Right now I am using CF7 Smart Grid Design Extension (Version 4.13.0)
    I am getting the following error while I try to save the Form. I am not able to save the data. Can the admin please will guide me on how to resolve that issue?
    Please see that link for screenshot. https://ibb.co/9GgPr99

    Thank you in advance

Viewing 15 replies - 16 through 30 (of 46 total)
  • You must be logged in to reply to this topic.