Support » Plugin: Country & Phone Field Contact Form 7 » Required Fields Not Working

  • Resolved avnongroup


    Although in the form both country and phone field are set as required fields, they dont show as required on the live site.

    How can I fix this?


    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Sorentk


    I second this,
    Although required it accepts only the country code, e.g. +1.

    Any news on changing this? I have to disable this plugin because it is vital that people fill out phone numbers.

    Plugin Author Narinder Singh


    Hi @avnongroup ,
    The contact form 7 plugin required and placeholder feature is working. But as you know there is a pre-fill dropdown.
    The phone number dial code field has dial code value.
    If the fields are not empty, required validation avoids them.
    For the phone number field, you can disable dial code from the plugin’s settings.
    I updated the plugin settings. Now you can disable country dial code and it will show empty field and test the required validation. It will work for you.
    Please update the plugin version.
    I hope the plugin is useful for you. If yes please give me 5 stars.
    Best Regards

    Plugin Author Narinder Singh


    Hi @sorentk,
    First of all apology for the late update,
    Please update plugin version. I added a new setting option for disabled the phone number dial code.
    I hope it will work for you.
    If the plugin is useful for you. Kindly appreciate my work with 5 stars rating.
    You can put more query support. I will try to keep updating.


    Thank you for your reply @narinderbisht !

    I am using this plugin thanks to it’s country code feature.
    Could there be an option of requiring a minimum length of the phone number?
    That way I could keep the country code, and also require the user to fill in the phone field.

    Thanks again!




    Hi, we are using the plugin for the dial code feature too, and we hit the same problem: the null value is not managed correctly….

    As @avnongroup suggested can you put a minimum length?

    Thank you very much

    Hi All, I noticed that the required on “phonetext” field is not properly working, by default it has a value of +1. Here’s my TEMPORARY fix:

    Add the following code to your custom js file.


    Or add this to your functions.php file

    function remove_phonetext_value(){ ?>
        <script type="text/javascript">
            (function($) {
                $(function() {
    <?php } 
    add_action('wp_footer', 'remove_phonetext_value');
Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Required Fields Not Working’ is closed to new replies.