Support » Plugin: Easy Digital Downloads » require login option doesn’t work

  • Hello,

    when I choose the “require login” option in download>setting>misc, the option box will become again empty as soon as I save the change.
    Could you please help me with this?

    Thank you so much

Viewing 5 replies - 1 through 5 (of 5 total)
  • Hi @gianlu77c

    I have checked the same option “Require Login” from Plugin Settings > Misc > Checkout and it is working fine.

    Once you save the option, please check by reloading the page again.

    If the issue is still there then please provide us which version are you using and are there any add-ons your are using with it.

    Hi @pratik-jain and many thank you for your kind reply.
    I’ve tried to save the option but, after the refresh, the option box becomes again empty and the change is not saved.

    The version is 2.9.14, italian version.
    I’m using the auto-repsonder add-on.

    Thank you once again

    Plugin Author mordauk

    (@mordauk)

    This is happening because you have the Auto Register plugin activated. When that plugin is activated, it forces the “require login” option to be disabled as customers will be automatically logged in during purchase.

    Many thank you @mordauk .
    It does make sense.
    But now I guess how I can manage the add-on in order to show the login and registration box at the checkout.
    I can’t find any backend option of the auto-register add-on.
    It still does permit checkout to guests now.

    Many thank you for the help

    Plugin Author mordauk

    (@mordauk)

    In order for the registration form to be shown, you will need to disable the Auto Register plugin.

    The registration form is removed since there is no need for it when user accounts are automatically created through Auto Register.

    If I’m misunderstanding what you’re trying to achieve, please let me know and I’ll be happy to elaborate on how it works.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘require login option doesn’t work’ is closed to new replies.