Support » Plugin: WooCommerce » Require Irish or any postcode on billing form

  • Resolved redlik

    (@redlik)


    Hi,
    I’m having trouble making the Irish postcode field to be required. I tried bunch of different snippets to include in functions.php file but none of them work. I finally found a line in woocommerce include/class-wc-countries.php file that listed Irish postcode:

    ‘IE’ => array(
    ‘postcode’ => array(
    ‘required’ => false,
    ‘label’ => __( ‘Eircode’, ‘woocommerce’ ),

    When I’ve changed ‘false’ to ‘true’ it finally worked but I know that’s the worst way to do it – changing core woocommerce code.

    Is there a good working snippet that will override this so when I update the plugin the change will stay?

    I’m running the latest woo 3.7.0

Viewing 1 replies (of 1 total)
  • Plugin Support Phillip C.

    (@phillipwoo)

    Hello,

    I’m glad you’ve found a way to update the issue for yourself. You may be able to use the Code Snippets plugin to apply the fix in a way that will not be overwritten at the next WooCommerce update.

    https://wordpress.org/plugins/code-snippets/

    Please let me know if this will work for you.

    Kind regards

Viewing 1 replies (of 1 total)
  • The topic ‘Require Irish or any postcode on billing form’ is closed to new replies.