Support » Localhost Installs » Requested url not found

  • rarebearnm

    (@rarebearnm)


    I’m new to WP. I am installing on a local host running CentOS 6.2 with Apache 2.2.15, php 5.3.3 and mysql 14.14. Joomla 2.5 is already installed and running fine.

    I followed the install steps from codex.wordpress. All steps went fine (??) until I got to access the blog. I get the following error:

    Not Found

    The requested URL /blog/wp-admin/install.php was not found on this server.
    Apache/2.2.15 (CentOS) Server at 172.16.2.241 Port 80

    Joomla is installed in /var/www/html. I setup WP in /var/www/blog. All of the WP files are in the blog directory. I can access the Joomla pages via http://ip.address. I was trying to access WP via http://blog/wp-admin/install.php to run the install script when the error pops up.

    Any idea where I went wrong in the install so far.

Viewing 6 replies - 1 through 6 (of 6 total)
  • esmi

    (@esmi)

    Forum Moderator

    What’s your web root url? I’m betting it’s http://ip.address/ – in which case, you have to either run everything under http://ip.address/ (which would mean moving Joomla to a sub-folder). Or you’d need to set up aliases in Apache to point to folders that are outside your web root.

    rarebearnm

    (@rarebearnm)

    yes the web root is presently ip.address. It will be changed when the server comes on-line.

    I think I would prefer to set up an aliase in Apache for the WP. I’m not sure exactly what is required, can you pleae provide the syntax? Many thanks

    esmi

    (@esmi)

    Forum Moderator

    They’re normally added near the end of your Apache http.conf file. One of mine (for example) is:

    Alias "/svg" "E:/data/data2/design/graphics/svg"
    <Directory "E:/data/data2/design/graphics/svg">
    Options FollowSymLinks Indexes
    AllowOverride None
    Order deny,allow
    Allow from 127.0.0.1
    allow from 192.168
    deny from all
    </Directory>

    which sets up http://ip-address/svg to point to a folder outside my web root. The first line syntax is:

    Alias "/alias-name" "Full-path-of-folder-this-alias-will-point-to"

    HTH

    rarebearnm

    (@rarebearnm)

    Ok that seemed to have fixed that issue. Thanks. But now I get a permissions issue:

    Forbidden

    You don’t have permission to access /blog/wp-admin/install.php on this server.
    Apache/2.2.15 (CentOS) Server at 172.16.2.241 Port 80

    Do you know what the unix permissions should be in the path leading up to and including install.php? I tried 777 on install.php and that did not fix it.

    rarebearnm

    (@rarebearnm)

    Is this a linux permssion issue or a result from httpd.conf and a Allow from command. In the conf file I used Allow from all and Oder allow,deny in the Directory block for the Alias. I want the world to access the blog site.

    rarebearnm

    (@rarebearnm)

    Problem solved.

    Couple of issues. All WP files had an owner of 33 and group of tape, as extracted from the .gz file. I changed own and group to be root:root for all WP files and directories.

    SELinux was still creating a permission issue. So I disabled SELLinux and access was granted.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Requested url not found’ is closed to new replies.