Support » Plugin: ecSTATic » Requested URI – feature request

  • Resolved wp.Man


    hi – liking this plugin allot!

    read a thread here that says that only one type of permalink can be logged and that is the reason the R-URI is often blank in the main/visitors page

    what i don’t understand though is why the R-URI for the same visitor is shown on the details page? why can’t that also be shown on the main/visitors page?

    example of visitor pg:

    Date/Time	Requested URI	Score
    02/27  05:52:38

    details pg for same ip/request:

    Date	Time	Referrer	REQUEST_URI	Meta URI	Score
    02/27	05:52:38		/soft/apps/sal/pad.xml

    showing here the 2 ways the R-URI is displayed:

    Date	Time	Referrer	REQUEST_URI	Meta URI	Score
    02/27	10:36:12		/research/law-enforcement	Page: Law Enforcement	0

    personally, on the visitor/main pg i would rather see “/” instead of “Page: home” and “/research/law-enforcement” instead of “Law Enforcement”

    maybe this could be added as an option or something? i would rather always see the actual path/URI personally

Viewing 15 replies - 1 through 15 (of 17 total)
  • Plugin Author MikeSoja


    Hello, wp.Man,

    There really shouldn’t be any blank R.URIs. I think the issue before was that after one switched WP Permalink settings, there would be a period of time when visitors were still submitting the old style links, with no way for ecSTATic to know how to parse them.

    It could be, though, that your Permalink setup is one that I did not thoroughly test, as there are a large number of possibilities.

    I like the idea of the raw output Option, and will look at the possibilities for the next version.

    hi Mike – thanks for the reply

    my link structure is ‘/%post_id%/%postname%’

    i have not changed it recently though – i guess i have used that for probably many months at least – but in my case many R-URI’s are blank – i would say ~70% (not including multiple entries/ip)

    but yes, i’m glad you are open to the raw output option 🙂

    many thanks!

    Plugin Author MikeSoja



    It looks like I did not account for your link structure, as it isn’t one I ran across in my testing.

    I shall attempt to rectify the oversight.

    Plugin Author MikeSoja



    I rewrote the fancy Permalink parser. I’ve always hated that section of code, and its spaghetti look showed it. I finally figured out a simpler, more complete way.

    I just sent version 0.983 up to the WordPress repository.

    Let me know if it works a little better for you.

    I didn’t manage to put an Option for raw view, yet, but it’s on the list of things to do. In the meantime, hovering your mouse over the URIs should show the original request.

    hi Mike
    still have the same number of blank R-URI’s, but the mouse-over does work

    i assume the code wasn’t yet added to fill in the blanks, so to speak? 🙂

    if so, no problem – not trying to rush

    looks like there is a bug though – if you disable visitors/feeds/bots from displaying in ‘ecSTATic (Main) Page Panels’, then the Maleagents page is blank (cept for the graph at top and hits table at bottom)

    Plugin Author MikeSoja


    If you view a Details page tab that shows the raw R-URIs, is there one type or another that doesn’t show up in the MetaURI column?

    For instance, it looks like I overlooked one of the many Date permutations.

    I did manage to add the Option to just output raw R-URIs, but it will be later today before I manage another update. Found some things to tweak that should make things run faster.

    The Maleagents page is just a special subset of visitor/feeds/bots, so whatever you turn off in the Main panel will turn off in the Maleagent panel, too.

    hi Mike
    on the details page, all of the raw paths are showing
    many of the meta paths are not, but that’s fine with me

    so if i am understanding you correctly, everything is working as intended and, after the next update, then the raw paths will be displayed on the main/visitor pages (if option enabled i presume)

    again, no hurry, and thanks

    Plugin Author MikeSoja


    I’m hoping to get all your metaURIs showing. Version 0.983 should have fixed most of the blanks. Will keep looking at it.

    Did you customize the Category base or Tag base options?

    Yes, you will soon have the option to display the raw paths only.

    nope – cats and tags options are default (blank)

    sample if it helps:

    ID#: 995.79   IP:   Domain:   Pages: 1
    UA: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.22 (KHTML, like Gecko) Chrome/25.0.1364.97 Safari/537.22
    Referrer: ◊
    Date/Time	Requested URI	Score
    02/28  16:20:05		          0

    Plugin Author MikeSoja


    Can you post some of the raw R-URIs that end up as blanks?

    i just noticed that some/many of the blank ones are language URI’s created by Transposh, which makes sense as to why the meta path is not displayed. here ‘zn’ and ‘de’ is the language which Transposh adds to the URI (i have it set to do so)…


    others are not language related however – these all result in blank meta links…


    so i can see where /tag/ and such would result in a blank meta link, but stuff like /photos/abandoned and /software/autoclipx are actual published pages

    a sample URI is…

    Plugin Author MikeSoja


    Thanks for those URIs.

    This one…


    … *should* be showing after yesterday’s update, so that’s interesting.

    The problems with the other ones is that the first… /zh/, /de/, /software/, etc., aren’t part of the standard set of WordPress Permalink tokens.

    But you want raw URIs, anyway, and that’s how they’ll have to be handled.

    Mostly done. New version later on today.

    Thanks for helping with this.

    Plugin Author MikeSoja


    Version 0.9841 has been sent up and should be available shortly.

    Let me know if it works!

    with the new option for raw URI’s disabled, looks like a lil bug (this is for old req’s that were already in the db as i don’t get allot of traffic – may not affect future); looks like allot of paths are having characters dropped and, maybe, sometimes added. for instance, i’m seeing:
    which, at the very least, should be:
    on mouse-over though, it looks like more chars may getting dropped – this is the tool-tip:

    another example – this is the tool-tip:
    but it’s being displayed as:
    /ddt /pad.xml
    notice also the added space in the above

    one more ex. – tool-tip:
    /t /uploads /burn-hoist.gif

    NOW – with the raw URI option enabled, everything looks good! all the paths look good and i’m not seeing any missing – /, /robots.txt, languages, etc. – all seem ok 🙂

    if you need anything more, let me know!

    Plugin Author MikeSoja


    Thanks for the feedback.

    I’ll look at the extra spaces, and everything after, say, org/ not being included.

    But it seems to me that there should be some difference between raw and abbreviated. 🙂

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘Requested URI – feature request’ is closed to new replies.