Support » Fixing WordPress » Requested theme does not exist.

  • I’ve been having a problem with the theme editor, I can edit the style sheet it loads up and when I go to theme editor and it saves but it tells me this afterwards “The requested theme does not exist.” and it also happens if click on another file to edit on the right side links it gives me that message. 3 out of the 4 themes I have installed do this, Classic, default, and Journalized-Sand. The Zig-zag theme works perfectly fine. And I also deleted the files posted in upgrading thread before uploading, went thru this step twice already with no success, I rstored the database and uploaded all the old files an tried again with no luck. It’s to late tonite but tomorrow i’ll try a fresh install.

    Any ideas on this, I haven’t touched any core files and I also tried changing permissions on the template files as suggested in another thread but to no avail. So I don’t know whats wrong, any help would be appreciated.

Viewing 8 replies - 1 through 8 (of 8 total)
  • Thread Starter hereatlast


    Well I did have some luck, I replaced the template-editor.php with the one form 1.5 and all seems to be. I’ll try to narrow it down further to exactly what’s causing it so if anyone else has this problem it will help them.

    You seem to be tripping over this change. I’m not sure why. I’m not seeing the problem with any of the dozens of themes I have installed for testing purposes. Please write a bug.

    I’m having the same problem. Using 1.5.1 with 3 themes installed. Haven’t touched any core files. Tried the permissions etc but they were already set correctly.
    Not a massive problem since I never really use the theme editor but a problem nonetheless. 🙂

    I can’t replicate the error.

    Fresh install of 1.5.1. Classic, Default, Journalized-Sand & Zig-Zag as the only themes installed.

    Also tested upgrade from 1.5 Nightly to 1.5.1 (overwrote and ran upgrade.php). Multiple themes, still can’t generate the error.

    Same problem here.
    Did a fresh install of WP on Mandrake 10 with PHP 4.3.4.
    Did nothing more than quick install/config and posted my first “Hello World”-entry. Went to the Themes part of admin and tried to launch the Theme Editor which just says:
    The requested theme does not exist.

    I’m running with absolutely no problem, could their be a bug in the newer ver.

    Moderator James Huff


    Volunteer Moderator

    I’m running with absolutely no problem, so there probably isn’t a problem in the newer version. This is probably an isolated issue due to a conflict with Roos’ server configuration.

    P.S. Sire, you have about three security holes open right now, two of them are public knowledge. An upgrade to v1.5.1.3 is strongly recommended.

    Solved this! (I’m not actually josepo, this is a bugmenot account.) This happens if you remove the commented-out sections at the top which include theme data. Reupload the CSS file with these intact and it’ll work.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Requested theme does not exist.’ is closed to new replies.