Support » Plugin: Cerber Security, Anti-spam & Malware Scan » Request to REST API denied

  • Resolved nimrod54

    (@nimrod54)


    Hi,
    I’m using Cerber 5.5. Under Hardening I checked “Block access to … REST API …”. After login I see under Activities Tab for my IP 3 URL marked “Request to REST API denied”

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Gregory

    (@gioni)

    Sorry, I have no idea. Cerber records all requests that have reached your website. That means there were 3 requests from your computer somehow.

    I have a similar issue with Cerber 5.5. I have blocked the REST API and overall I see a number of “random” requests that the plug-in now protects me from.

    Normally I put my home IP in the white list; but I am currently away from there – and so I am signing on. This is logged with my IP.

    I then see a series of rejections using my IP with the URL site/wp-json/jetpack/v4/jitm while we are on the admin page.

    We do have Jetpack installed – so I assume that Jetpack are now wishing to use the REST API. Doubtless other plugins will follow this route.

    The code itself is in /wp-content/plugins/jetpack/_inc/jetpack-jitm.js

    Would it not be reasonable to say that a currently logged-on user would be able to use the API – and not reject them? [I do understand that a rest request coming from a non-logged on user session is more tricky to detect – and would be rejected.]

    Plugin Author Gregory

    (@gioni)

    @lcyh78 That’s absolutely reasonable and will be implemented in the next version soon.

    For now you can whitelist the whole jetpack route by entering jetpack namespace into REST API whitelist.

    P.S. https://mattreport.com/disable-jetpack-upsell-ads/

    Thank you for rapid response.

    Entering jetpack into the whitelist has stopped the messages. Though clearly I don’t have need for this specific underlying functionality.

    Thank you for taking the idea into consideration and look forward to the release when it arrives.

    Plugin Author Gregory

    (@gioni)

    Check out the latest development version: https://wpcerber.com/development-release-5-6-5/

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Request to REST API denied’ is closed to new replies.