Support » Plugin: Minimal Coming Soon & Maintenance Mode – Coming Soon Page » Request Entity Too Large – Backslashes!

  • Resolved dastru

    (@dastru)


    Hi Guys, I just wanted to share that I have been getting an error where I would see the following message:

    “Request Entity Too Large
    The requested resource
    [/wp-admin/options-general.php]
    does not allow request data with POST requests, or the amount of data provided in the request exceeds the capacity limit.

    I tried increasing the memory limit, but that didnt work.
    After doing some more research and digging I noticed that there’s a bug in the plugin, which adds backslashes to the “Message: Successfully Subscribed” field between “We’ll” in ‘Thank you! We\\\’ll be in touch!’

    Hope to help solve some issues for you guys.

    https://wordpress.org/plugins/minimal-coming-soon-maintenance-mode/

Viewing 6 replies - 1 through 6 (of 6 total)
  • Got that error today. Thanks for pointer as I was coming here to report same issue.

    Never saw it before so has to be influenced by new WordPress release as I haven’t changed my maintenance page settings in a year. I also don’t use the subscription form where this bug is located.

    I followed your advice and looked in the field and to my shock/horror found over 500,000 slashes in my field.

    How on earth did that get there????

    Same problem here, any fix ?

    @zerrogh

    The temp fix (aka without plugin author updates) is to:

    1. goto the plugin configuration > Email settings page.
    2. locate the “message subscribed field” at bottom right of page.
    3. completely replace field contents with a new “Thanks for subscribing” message

    I suggest using the TAB key to move between form fields as this allows you to select ALL the field contents in one easy step.

    In my case I has over 500000 slashes and holding down [DELETE] to remove a character at a time wasn’t even making a dint.

    @snaphappyme Great idea!
    That seems to be working for me.

    Not sure if it has to do with other/third-party plugins, but so far I’ve encountered that same issue on multiple WP installations that I manage.

    Normally I would just be deleting the slashes ever so often. Didnt even think about replacing the message. 🙂

    I did a bit of poking around the code of the plugin.

    This plugin is pretty benign with its handling of the form field content so I don’t think it is a plugin logic error. I think a dependency library or PHP core function used by the author has changed and triggered the bug.

    I suspect it has to do with the PHP strip_tags function which is used to ‘cleanse’ or treat the field before posting the value to the database.

    Perhaps the handling of a pre-existing ‘slash\’ in the default string is being handled differently now with the latest PHP code updates.

    Nonetheless it is a bug. But as we know a way around it we can at least keep using the plugin safely.

    Plugin Author WebFactory

    (@webfactory)

    Hi, thank you for reporting this bug! It’s been fixed in the new version which will be available in a few days.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Request Entity Too Large – Backslashes!’ is closed to new replies.