Support » Plugin: Gallery Custom Links » [request] Disable link with [none] as URL

  • Resolved wwwolf

    (@wwwolf)


    Thanks Jordy for this great replacement for the old WP Gallery Custom Links plugin – would it be possible to restore one more piece of the old functionality? It’s the option to disable the link altogether by entering [none] in the URL field.

    Use Example:
    I have a ‘Meet the team’ gallery, and some of the staff have profile pages and some do not. The old plugin made it easy to distinguish, by just disabling the click-through for thumbnails for which there’s no associated profile page. Even better, since that removed the ‘a’ tag altogether, I could also use a css mouseover ‘animation’ to indicate this, without having to click. Now, unfortunately, they all behave the same, and the ones without profiles just ‘404’ πŸ™

    Many thanks!

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Jordy Meow

    (@tigroumeow)

    So if [none] is present as the URL, the plugin should look for the enclosing link and remove it, that is right?

    If yes, could you contact me directly here?
    https://meowapps.com/contact

    I would like to share with you a fresh install so that you could try to use the new version of the plugin with that feature, and check if it works with your use case (so basically you will need to replicate that usage on my install).

    Thanks Jordy – I’ve sent you screenshot, link and my contact details πŸ™‚

    OK – it’s solved – with rapid and very helpful assistance from Jordy. Very impressed with this level of support πŸ™‚

    Here’s a copy of the final diagnosis, and how to fix if you encounter a similar issue:

    The difference between the old plugin and your new one is simply treatment of the Gallery default setting for links!

    The old plugin completely over-rode the setting in the Gallery itself with whatever you set in the URL field for each image, and you created “no link at all” by entering [none] β€” so I didn’t pay much attention to that setting in each Gallery, it was irrelevant.

    Now, the URL field is interpreted literally, so [none] is interpreted as a URL and put in place. And now, if the field is left blank, it drops back to whatever was set as the Gallery default. I was puzzled by different behaviour in different galleries β€” this was because the settings in them were different! So I can get back to the old behaviour simply by ensuring that the Gallery default is set to ’none’, and then leaving the URL field blank in the image settings.

    On reflection, I think this is actually probably better than the old behaviour. Anyone migrating – if you need to have some images with no links, simply:
    1) edit the Gallery and set the link default behaviour to ‘none’;
    2) delete the [none] setting from any images you want to have no link at all, and leave it blank (can be done in phpMyAdmin fairly simply if you have a lot).

    Job done – and thanks again Jordy, you’re a star!

    Plugin Author Jordy Meow

    (@tigroumeow)

    You are most welcome, and thanks a lot to you too for looking into all this! No doubt it will help others too πŸ™‚

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘[request] Disable link with [none] as URL’ is closed to new replies.