WordPress.org

Support

Support » Plugins and Hacks » Slideshow » [Resolved] Request: check for ability to use PHP before showing snippets

[Resolved] Request: check for ability to use PHP before showing snippets

  • Heya!

    In the form for adding/editing a slideshow, there are two parts right now that give PHP snippets. With the rise of multisite networks, and other role/capability environments, I think it’s a really nice feature to wrap any PHP snippet output in code such as the following:

    if (current_user_can(‘edit_themes’)) { /* php snippet examples here */ }

    This way, people who can actually use php on the server get to see the message, and those who don’t have that right aren’t confused.

    Thanks for considering this for a future release. Cheers

    http://wordpress.org/extend/plugins/slideshow-jquery-image-gallery/

Viewing 1 replies (of 1 total)
  • Plugin Author Stefan Boonstra

    @stefanboonstra

    Hi,

    Thanks for the suggestion and the clear explanation, I understand why it could be confusing. The PHP snippet will be hidden from lower-level-users in the release of version 2.1.19.

    Best regards,
    Stefan

Viewing 1 replies (of 1 total)
  • The topic ‘[Resolved] Request: check for ability to use PHP before showing snippets’ is closed to new replies.
Skip to toolbar