I suggest that those who write plugins use a prefix on their functions so they do not end up duplicating functions in other plugins. For example, wp-advanced-stats and wp-contactform both use the function getip(), so I had to go into the contactform plugin and rename it.
It would eliminate this potential problem if plugin writers would make their functions something like wpas_getip() and wpcf_getip() respectively for the 2 plugins listed above.
Thanks in advance for this considerations 😉
- The topic ‘[REQ] Standard Plugin Function Naming Conventions’ is closed to new replies.