[REQ] Standard Plugin Function Naming Conventions (3 posts)

  1. philpeeps
    Posted 11 years ago #

    I suggest that those who write plugins use a prefix on their functions so they do not end up duplicating functions in other plugins. For example, wp-advanced-stats and wp-contactform both use the function getip(), so I had to go into the contactform plugin and rename it.

    It would eliminate this potential problem if plugin writers would make their functions something like wpas_getip() and wpcf_getip() respectively for the 2 plugins listed above.

    Thanks in advance for this considerations ;)

  2. Nick Momrik
    Posted 11 years ago #

    Great idea Phil! I plan to update all of my plugins over the weekend and will definitely do this.

  3. ColdForged
    Posted 11 years ago #

    Yup, I had already done that after noting the problem between the plugin manager and the theme manager (though now that I look there are some lingering "genericky" names in my spell checker, dang it). Good thought!

Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.