Support » Plugin: Events Manager » Report Error: after updating to Events Manager 5.7

  • Resolved Qored

    (@qored)


    Hello,
    I’m using WP multisite version,
    after updating to Events Manager 5.7 I got this warning

    The plugin generated 3 characters of unexpected output during activation. If you notice “headers already sent” messages, problems with syndication feeds or other issues, try deactivating or removing this plugin.

    and then my WP admin panel turned into white page unless I remove the plugin from cPanel.

    Hope a quick update released soon fixing this issue.

    Thanks for all your hard work on that great plugin & Best regards,
    Qored

Viewing 13 replies - 1 through 13 (of 13 total)
  • Plugin Support angelo_nwl

    (@angelo_nwl)

    sorry but we are not getting this error after upgrading EM; can I know what is your php version and can you try to check your php logs to see if there’s any other error?

    I also have a multisite with the same issue, php version 5.6, I don’t know how to check php logs I’m afraid. Hope you can help asap, I’m locked out of my subsites.

    Plugin Author Marcus

    (@netweblogic)

    NetWebLogic Support

    hi, just to let you know I’m looking into the issue, although I’m still not able to reproduce this myself I do have access to a Pro customer with the same problem.

    Do any of you have access to error logs? The current one I’m working off is :

    Warning: Cannot modify header information – headers already sent by (output started at /…/wp-content/plugins/events-manager/admin/em-ms-options.php:1) in /…/wp-includes/pluggable.php on line 1195

    Also, what hosts are you using? The line of code referenced in this error is perfectly OK so I’m currently at a loss to what’s happening, but looking into it with intention to fix within the day.

    • This reply was modified 4 months, 1 week ago by  Marcus.
    Plugin Author Marcus

    (@netweblogic)

    NetWebLogic Support

    Also, if you can let me know your PHP versions that’d be helpful. There’s two users with 5.6 so there’s a pattern there possibly, although I still don’t get why that’d matter, based on the error above vs. what I see in that line of code.

    Hi Marcus
    I think I’m the pro customer you have admin access to. My hosting is with TSO host shared cloud hosting, do you need more technical details? Let me know what specifically please.

    I get the same warning today after update from 5.6.6.1 to 5.7
    Warning: Cannot modify header information – headers already sent by (output started at /…/wp-content/plugins/events-manager/admin/em-ms-options.php:1)

    I just replased em-ms-options.php file from 5.6.6.1 backup
    Problem was fixed

    • This reply was modified 4 months, 1 week ago by  nohcho82.

    Im switched from php v5.6 to php v7.0 and the problem fixed.
    hosting in Siteground btw.

    I just upgraded to php v7.0 – still the same issue.
    Should I replace em-ms-options.php from my backup?
    I’m worried that when I log out of the network admin I won’t be able to get back in as with the subsites.

    Plugin Author Marcus

    (@netweblogic)

    NetWebLogic Support

    Hi Everyone,

    If you could try out the latest dev version, the problem seems to be fixed, would appreciate a confirmation as this will be released as a stable within the hour.

    http://wp-events-plugin.com/documentation/upgrade-dev-version/

    Marcus –

    Is the ability to turn on dev updates available in a Network install? I don’t see an “Admin Tools” block for a site in a Network install that is using this plugin.

    We are getting the same error as described above, and we are running on php 5.6.

    Plugin Author Marcus

    (@netweblogic)

    NetWebLogic Support

    Hi, you should be able to do it from the network for MultiSite environments. However, we’ve updated the plugin now to a stable release. We’ve tested this on a few setups and it seems to have fixed the issue.

    Plugin Author Marcus

    (@netweblogic)

    NetWebLogic Support

    Hi, we’ve just released 5.7.1 which specifically fixed this issue and I confirm it’s working fine on yours now. The problem arose from a oddly formatted ? in the first line of that file: <?php

    I’m still not sure how or why it happened, it’s likely the file got corrupted somewhere along the way because the only way to fix it was to overwrite with the old file and manually adding the one line of code we modified in the last update.

    Thanks for your patience and sorry for the inconvenience!

    Thanks alot, works fine 🙂

Viewing 13 replies - 1 through 13 (of 13 total)
  • You must be logged in to reply to this topic.