Support » Plugin: Yoast SEO » Replytocom removal breaks WP Touch Pro nested comments

  • Resolved Markurs

    (@markurs)


    The v7.0.2 release removes the replytocom option. This now breaks nested comments for mobile theme users using the WP Touch Pro plugin as it relies on replytocom to work.

    I received the code from another thread:
    https://wordpress.org/support/topic/how-to-get-replytocom-back/

    add_filter( 'wpseo_remove_reply_to_com', '__return_true' );

    However, I cannot get this to work as adding it into the mobile theme does not seem to solve the issue (desktop theme is unaffected by replytocom)

    I have tried inserting the above code in to various locations within the WP Touch plugin, all without success though:

    – wp-content/wptouch-data/themes/classic-redux/root-functions.php
    – wp-content/wptouch-data/themes/classic-redux/default/functions.php
    – wp-content/plugins/wptouch-pro/themes/foundation/root-functions.php
    – wp-content/plugins/wptouch-pro/themes/foundation/default/functions.php

    As a last resort, I also tried inserting it in to the standard functions.php file, also without success as my desktop theme does not rely on replytocom only the mobile site.

    Any further ideas would be greatly appreciated.

Viewing 15 replies - 1 through 15 (of 16 total)
  • Plugin Support Rumejan Barbarona

    (@onlyincebu)

    Have you tried performing a conflict check to see if some other plugins may have contributed to the issue? You may refer to this kb article: https://kb.yoast.com/kb/how-to-check-for-plugin-conflicts/

    Well, I have the same issue: on the comments area, the link “Reply” doesn’t working. Normally at the click site scrolling on the comment textarea, now it’s not. We have two site, a production with Yoast Premium 7.0.2 just updated, and a develop with Yoast plugin disabled. In the test site, the Reply to comment links are working and Reply ha a link like this:
    url/?replytocom=14104#respond
    In the production, it’s not working and it has this type of link:
    url/#comment-16533

    WordPress is 4.9.4 version in both sites. It’s not the template theme, because we have already check it with their support, production and develop are aligned with same version and files. We have disabled all the plugin, one to one, on the production site ad found that its’ Yoast to make this error. If we disabled it, Reply to comment links come back to work!
    It worked great before this last update. So, can you check the code please?
    Thank you.

    Hi Rumejan Barbarona, removing Yoast wordpress SEO makes the nested comments in WP Touch Pro work again. The conflict is the removal of Replytocom from Yoast v7.02 which WP Touch Pro uses to operate its reply function in its comments. In previous versions turning off the removal of replytocom in Yoast SEO solved this issue and both plugins played nicely with each other. Since this option is now deprecated, issues have arisen.

    The code supplied to turn off the filter in the thread i linked to above is wrong. It should be:

    add_filter( 'wpseo_remove_reply_to_com', '__return_false' );

    where return_false is used instead of return_true. Inserting this into WP Touch’s functions.php file solves the issue.

    However, with two mainstream and well used plugins causing conflicts, surely this replytocom removal issue needs to be addressed? Not sure why the plugin user cannot decide whether to remove them or not? The default option in previous versions was to always remove them so I am not sure why your users cannot continue to decide for themselves?

    As a paid premium plugin user, I am deeply disappointed. I have received yet from the paid suppert the same solution, the filter in the functions.php file.
    This can not be a valid solution. And above all, I don’t accept it from a paid plugin. I don’t touch the wordpress core code, which will be overwritten the next WP upgrade.
    If Yoast has introduced a change, since version 7.0.2, and so it’s, because if you disable the plugin everything goes back to working, then it must be Yoast to insert a change to its code.
    In this case, a check in their panels that enable / disable this function.
    And I don’t expect anything less than this.

    Plugin Support MariusG

    (@marius_codeinwp)

    @markurs thanks for pointing out the mistake, the correct code to enable ?replytocom variables is indeed:
    add_filter( 'wpseo_remove_reply_to_com', '__return_false' );

    @barbarawebnauta @markurs the solution to add the snippet from above without losing it at the next theme update is creating a child theme and adding that snippet in the functions.php file of the child theme.

    This will allow you to update your WordPress theme and plugins without losing the snippet to enable ?replytocom variables.

    I repeat: this is not a valid solution for a paid plugin.
    An error in your code, which I already pay, translates into paying another person to create a child theme for the theme I already pay, with other assistance and warranty issues. Do you see the absurdity or not?!

    I agree. This is not a valid solution. I spent half the day figuring out which plugin the culprit was after one of our users reported the issue.

    For users who have the same problem, this is the service response this evening: We understand the concern and know that in some circumstances it may make sense to have the replyto variable. We’ve gone ahead and created a feature request for our developers to consider bringing the feature back. We’ve added you to the list to be contacted.
    You can follow it here: https://github.com/Yoast/wordpress-seo/issues/9226

    So, we just have to wait confidently.

    Plugin Support Michael Tina

    (@mikes41720)

    @andyaffleck @barbarawebnauta @markurs

    Thank you for the input. As @barbarawebnauta mentioned, we’ve opened a feature request to possibly re-introduce the option of enabling or disabling the replytocom variable without having to result to a filter. Our developers will review this accordingly and provide feedback at the soonest possible time. We’ve also referenced this thread in the GitHub issue.

    Plugin Support Michael Tina

    (@mikes41720)

    No further response so we’re setting this to resolved for now.

    Words cannot describe how much I despise Yoast right now. I didn’t realize this was broken right away because I handle my comments on the backside. But readers of my blog who weren’t using the mobile version of the site started complaining that they could no longer reply to comments. I verified this on all PC browsers, so I went to my sandbox and even when all other plugins except Yoast were removed, the reply functionality was still broken.

    It irritates me to no end that someone thought, “Yeah, lets remove reply functionality for some sites ’cause ‘reasons.’ That’s awesome development by half!” And then the real, awesome response on the part of Yoast is for us to modify our child themes (or make them if we don’t have them) to include a line of code.

    It’s exactly the same that I thinked. Now, I look confident the change, I hope not in six months…

    @mikes41720 no, it’s not resolved by far. I’ve just spent the entire yesterday trying to figure out the same issue, until I disabled Yoast, so I finally could reply to existing comments. I even posted a new topic in the support area before I saw this thread. With all its benefits, I can’t use Yoast right now because for me the reply to option is big. I guess I should consider myself lucky that I’m not a paid member.

    • This reply was modified 1 year, 3 months ago by  kislany.

    So, my users continue to complain about the failure of the reply button, the comments are no longer nested and I lose readings and discussions… How long do we have to wait for the change? Is there a plan for the release?

    We are having the same issue. “Reply” is important to our site. For now, Yoast is deactivated.

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘Replytocom removal breaks WP Touch Pro nested comments’ is closed to new replies.