Support » Plugin: Contact Form 7 » Reply to: [your-email] no longer works in just one form

  • I have 17 contact forms in this WordPress installation. Flamingo and GeneratePress are active. All forms except one work fine. In this form, only if I delete Reply-to: it works again.This form has worked well for years. Now, the form is saved in Flamingo but the mail is not sent.

    The same configuration, in the same installation, with Reply-to: and other headers in the rest of the forms works fine.

    Domain mail is hosted in Google. Spf, Dkim and Dmarc are correctly configured. I don’t use SMTP plugin. I have tested in PHP 7.3 and PHP 7.4.

    I have installed WP Mail Catcher – logs and it shows this error https://imgur.com/3Aq9ms1

    Can anybody help me? Thank you very much in advance.

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Hola, Angeles:

    Este error suele generarse cuando tu proveedor restringe las funciones mail() y/o wp_mail(), pero si estás recibiendo mensajes de correo desde otros formularios de la misma web, este no sería el caso.

    Te haré dos preguntas para intentar ayudarte a resolver el problema:

    1. ¿Revisaste si estás usando Reply-To: [your-email] en lugar de Reply To: [your-email] (sin el guion) en las Cabeceras adicionales?
    2. ¿Puedes mostrar una captura de la configuración que tienes en la pestaña Correo electrónico del modo edición de tu formulario?

    Saludos cordiales,
    Yordan.

    Thread Starter Angeles Portillo

    (@enana)

    Gracias por contestar tan rápido, creo que he revisado todo lo revisable, el resto de formularios (16) funciona sin problema con la misma configuración, no hay restricciones del servidor. Adjunto capturas.
    https://imgur.com/a/poGiFxv

    También creé el formulario de nuevo. Si pongo la etiqueta Reply-to: solamente funciona con dominios específicos (no genéricos). Mails con reply-to a gmail, yahoo, etc. no son aceptados.

    Thanks for answering so quickly, I think I have reviewed everything that can be reviewed, the rest of the forms (16) work without problem with the same configuration, there are no server restrictions. I attach screenshots. https://imgur.com/a/poGiFxv

    I also created the form again. If I put the Reply-to: tag it only works with specific domains (not generic). Mails with reply-to to gmail, yahoo, etc. are not accepted.

    • This reply was modified 2 months, 3 weeks ago by Angeles Portillo. Reason: complete information

    Hola, Angeles:

    No veo problemas en tu configuración, así que esto tiene pinta de estar siendo generado por tu servidor de correo que quizás esté aplicando algunas restricciones. Mi recomendación es que pruebes configurando un plugin SMTP para comprobar si el problema se soluciona. Si lo hace, sabrás que el origen del problema está en el servidor de correo.

    Yo tengo una configuración parecida a la del formulario que dices que no funciona, de los que muestras en la captura de pantalla, y funciona correctamente.

    Saludos cordiales,
    Yordan.

    Thread Starter Angeles Portillo

    (@enana)

    Muchas gracias Yordan,

    lo realmente misterioso para mi es que los otros 16 formularios no den ningún problema y solamente este es el que lo da desde la última o penúltima actualización. Llevaba más de seis años funcionando correctamente. He visto en los foros que otras personas están teniendo el mismo problema.

    Como comenté, la parte del servidor parece descartada, ya estuvimos revisando y todos los demás formularios funcionan a la perfección.

    Desactivé todos los plugins y tampoco se solucionó. También creé un correo no-reply real.

    También pensé en probar con un plugin de SMTP, y si fuera un sitio personal con menos usuarios ya lo habría hecho, el tema es que cada formulario debe salir y llegar a diferentes correos de la organización. Seguramente volveré a probarlo de forma más concienzuda.

    Thank you very much Yordan,

    The really mysterious thing for me is that the other 16 forms do not give any problem and only this is the one that gives it since the last or penultimate update. It had been working properly for more than six years. I have seen on the forums that other people are having the same problem.

    As I commented, the server part seems discarded, we have already been checking and all the other forms work perfectly.

    I disabled all plugins and it was not fixed either. I also created a real no-reply email.

    I also thought of trying an SMTP plugin, and if it were a personal site with fewer users I would have done it already, the issue is that each form must go out and reach different emails in the organization. I will surely return to test it more thoroughly.

    Hola, Angeles:

    Es cierto, varias personas han reportado casos similares al tuyo y los que han solucionado, y vuelto para explicar como lo hicieron, confirman lo que te digo: es un problema con el servidor de correo.

    Yo mismo tengo decenas de sitios donde uso formularios de Contact Form 7 con distintas configuraciones y todos están funcionando. En realidad, CF7 solo gestiona el manejo y proceso de los datos que se envían desde tus formularios, pero el envío de correo depende de tu servidor de correos, no de CF7.

    Si usas un alojamiento compartido, debes asegurarte de que el proveedor no tiene restringidas algunas funciones o nombres de dominio. Si el caso es que usas un VPS o un servicio Cloud, debes comprobar que tu servidor de correo esté bien configurado.

    Leyendo tu primer mensaje, deduzco que no eres una usuaria promedio, sino que tienes conocimientos más avanzados. Así que mi recomendación es que, si tienes un servidor de pruebas en un proveedor diferente, hagas una copia del sitio allí y pruebes enviando mensajes sin SMTP y luego con SMTP.

    Saludos cordiales,
    Yordan.

    Thread Starter Angeles Portillo

    (@enana)

    Gracias de nuevo Yordan
    Cuando pueda realizar las pruebas de nuevo comentaré por aquí el resultado por si a alguien le sirve de ayuda.

    Thanks again Yordan
    I will have new tests and comment the result here.

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.