Support » Plugin: Contact Form to Manage and respond to conversations with customers — HappyForms » Setting Reply-To so it’s from the sender?

  • Resolved kaizerco

    (@kaizerco)


    When I reply to an email from the contact form, the reply is addressed to the email where the form is coming from, rather than to the email of the person who filled in the form.

    How can I set the reply-to so it comes from person who filled in the form?

    Thank You!

    • This topic was modified 1 year, 1 month ago by kaizerco.
Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author thethemefoundry

    (@thethemefoundry)

    Hey there, @kaizerco!

    I guess you’ve already checked this, but your form should contain an Email part. Once that’s done, HappyForms should take care of the rest. If that doesn’t happen, we’ll need to investigate deeper.

    1. Could you share a link to your form? I’d like to try a test submission.
    2. After my submission notice lands in your inbox, I’d ask you to share the complete headers of that message: From, Display Name and Reply To.
    3. If something’s off, I’d suggest you to install an SMTP plugin. To be honest, I’d suggest it anyway, as SMTP ensures all HappyForms mail features work correctly, and prevents your email from being spam-flagged.

    Let us know your discoveries!

    Hi there,

    It appears that if I reply from an iPhone it works fine – It replies to the sender. If I reply from gmail it replies to the sending email.

    I am using an SMTP sender.

    I sent you the contact form URL by email.

    I think this might be a gmail issue that’s been going on for a while.
    I do remember my reply-to’s working before…

    https://productforums.google.com/forum/#!topic/gmail/aVlo3QqT7MY;context-place=topicsearchin/gmail/gmail$20reply$20to

    Ok, there is a workaround solution to this – from:
    https://wordpress.org/support/topic/reply-to-doesnt-work-anymore-in-gmail/

    This happens when the sending email address and the gmail address that receives the contact form email are the same address or are aliases of the same address.

    The workaround is to use a different email completely either for sending or for receiving. Not much fun! but it seems to be the only solution right now.

    Plugin Author thethemefoundry

    (@thethemefoundry)

    You’re right, @kaizerco!

    It’s indeed a Gmail quirk. We hoped using a Gmail alias (your.email+alias@gmail.com) could be a workaround, but it turns out it isn’t.

    For the record, we’re using Reply To header instead of From header because most email providers won’t let you send an email from your SMTP account with an address which is different from the one linked to the SMTP account itself.

    We’ll be keeping an eye on this, and possibly add a way to switch between Reply To and From headers. That should hopefully help!

    Let us know if we can help in any other way. 🙂

    Cool. Good to know you’re aware of the issue.
    Let’s hope there’s a solution on the horizon. 🙂

    Plugin Author thethemefoundry

    (@thethemefoundry)

    Glad we could help clear that up!

    Let us know if ever have more questions for us!

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Setting Reply-To so it’s from the sender?’ is closed to new replies.