Support » Plugin: Contact Form 7 » Reply-To in Additional headers is being ignored

Viewing 13 replies - 1 through 13 (of 13 total)
  • [EDIT: It is working. It was a caching issue on my part. Oops! My apologies.]

    I’m experiencing the same issue as well. The form works. The email sends. I receive it, but when I click reply, it sends to my email address instead of the user entered one.

    On the Form tab I have: [email* your-email]
    On the Mail tab I have: Additional Headers: Reply-To: [your-email]

    I should note mail is being sent through Gmail SMTP. Unsure if this may be a factor in the issue.

    Thanks in advance for any help on this.

    [EDIT: It is working. It was a caching issue on my part. Oops! My apologies.]

    • This reply was modified 1 year, 1 month ago by  mattrock1. Reason: Incorrectly stated there was an issue with additional headers, when the issue was on my end
    smallstar67

    (@smallstar67)

    From what I’ve heard, Google is no longer supporting the reply to in the header. So if you hit reply on an email sent from the contact 7 form, it puts your email address in the reply field ,thus sending mail back to yourself.
    With the reCaptcha v3 failing massively, no one has addressed this issue, but it is a BIG issue..

    I think this explains why mine stopped working recently. I’ve disabled the captcha but now still have the problem with emails replying to myself so I have to copy and paste from the form into the reply to and delete my email address each time I get an enquiry. So annoying and looks like there’s no fix I guess. What is everyone doing?

    I can’t find much info on all this. I’ve reached out to WPforms to see if they know anything about it. I’ve checked all my SMPT plugin settings and haven’t changed anything recently.

    I have the same problem and so far I didn’t find any solution yet

    Did Google just change this recently? If so it would be nice to have a warning from them when it happens that your business is about to suffer and you will waste hours trying to fix something that simply can’t be fixed anymore. I’m so sick of things just breaking from some issue beyond my control while the giants who cause it continue to grow and make money from all our hard work getting their crap product to work.

    I’m in this boat too 🙁

    I feel your pain.

    Now my form isn’t even scrolling to the ‘Thank You for Contacting Us’ message (form area on my page) after my customer fills it out. This is causing the issue where they fill it out again thinking it hasn’t been sent. I’ve had both these problems before and spent hours fixing.

    I can’t believe how hard it is to simply maintain a working contact form on a website in 2018,
    I remember going through all these problems over 10 years ago. Nothing changes!

    Now I have no captcha, no easy way to reply to a customer form, and no more patience, I give up, until I find a decent solution or at least someone to acknowledge why this has happened and with what update. Going around in circles looking at SMTP settings, API’s and things that I don’t dare change because it all was working with the existing settings still in place.

    Hello @smallstar67

    do you have a official source of this information?

    Thank you
    Tom

    I’m having this issue as well and just have had a support chat with google.
    Since they could not resolve the issue, a support ticket was opened where they stated following:
    Thank you for contacting the G Suite Support Team. This is (name removed for privacy) and I apologize if our interaction was halted. I am eager to help you resolve your concern but the time for the investigation with the email needs more time. While we were discussing about your issue, i researched and found out that this case is already a Known Issue which already occurring in some users as well when using the New Gmail UI. I also filed a report in your case that is also affected by this Known-Issue and will wait for further notice from the Engineering Department who’s already working on it to fix this issue.
    As a workaround for the meantime, Engineering team advise:
    1.) When replying, first update the address that you would like to send the message to.

    So many of us using cf7 and gmail have to a lot’s of copy and paste work to do for the next month I’m affraid. I’m helping myself with putting the reply-to address also at the end of the message body, something like :”this mail was sent from my.tld from reply-to@address.tld” so at least I’m having the mail address nearby for copy&paste.

    good luck
    Tom

    PS: and of course it is definitely not a cf7 but a gmail issue!

    Yes, lots of extra work, its getting annoying, especially if I forget which keeps happening then I have to go to my inbox, delete the one that came to myself and do it again.

    And to think we pay for the privilege of using this superior way of doing business in 2018. I was quicker at daily tasks on the pc in 2004 when I first started, and I was doing the same thing back then, simply replying to inquiries from a contact form. Now its my full time job almost and I make less money because of crazy stuff like this slowing me down daily! And paying for all this extra crap just so we can operate online.

    I’ve tried a number of alleged fixes like “No-Reply@yourdomainname.com” So far nothing works. The best temporary fix is to have the customer’s real “reply-to” addy listed in the mail headed so you can quickly copy and paste it into the address field once you have started a reply in Gmail.
    Everyday I hope it’s fixed by google but so far that is not the case.

    There is a temporary fix for this – I just tried it and it works stackoverflow.com

    The issue with Gmail is also discussed at Reply-to doesn’t work anymore in Gmail.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Reply-To in Additional headers is being ignored’ is closed to new replies.